Support » Plugin: SG Optimizer » Defer Offscreen Images warning after update

  • Resolved someka

    (@someka)


    Hello,

    I don’t know what can be the reason for this but when I updated the plugin from 5.3.0 to 5.3.5 I started to receive that infamous “Defer offscreen images” from Google PageSpeed Insights.

    I was unsure about how can this be related to the plugin. Went to my staging > ran the test with 5.3.0 and no defer images warning > just updated the plugin and receive the warning now 🙁

    Any ideas?

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Just found out after a few tryout and playing with the settings, it looks like “Defer Render-Blocking JS” setting has something to do with it. When I toggle it off completely, the warning goes away.

    I still don’t know what is the relation but at least we specifically know the guilty part 🙂

    (but I still need that option, so we’ve better get a fix soon)

    Plugin Author Stanimir Stoyanov

    (@sstoqnov)

    SiteGround Representative

    Hey @someka

    I’ve excluded some of your scripts and the notice for the images is not an issue anymore.

    Regards,
    Stanimir

    Hello Stanimir,

    Thank you for sparing time to do that BUT logging into my backend and adding some code without my permission is not an appropriate way to do that. I prefer doing changes under my own control (in order to be able to know what has been changed for future)

    I guess you have added a custom filter to child theme functions.php, right? Is there anything else?

    (please let me know if this permission issue is a setting under our Siteground panel so that I can change it)

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    Sorry for this, it won’t happen again, we were discussing your case and how to handle such problems in the future and I’ve forgotton to open a ticket on your behalf and actually replied you here.

    Yes, we’ve excluded the scripts that were malfunctioning from being deferred with filters in the functions.php file because the interface we have in the plugin did not detect them. That’s because they’re included in an….unorthodox way to the footer.

    Ideally, troubleshooting this would be as easy as trying to exclude the registered scripts but unfortunately not everyone follows strictly the best practices for registering scripts.

    Thank you Hristo for explanation.

    Again, that’s not a complaint and I am sure there are lots of users who will be happy when you just move forward, access backend and solve the issue. I am just not one of them 🙂 (would be great if you had a panel setting for these kind of cases)

    Anyways. Have a nice day!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.