Support » Plugin: SG Optimizer » Defer javascript loading adding # to .js url

  • Resolved agilejoshua

    (@agilejoshua)


    The defer/async setting doesn’t seem to work nicely with wordpress builtin enque script version cachebusting. I am using a simple filemtime timestamp.

    With defered loading off I am getting the correct path
    src=”/path/to/script.js?ver=1571824457″

    With defer on I get:
    src=”/path/to/script.js?#038;ver=1571824457″

    The script still works but cache busting does not.

Viewing 1 replies (of 1 total)
  • Plugin Author Stanimir Stoyanov

    (@sstoqnov)

    SiteGround Representative

    Hey @agilejoshua

    Thanks for reporting this. Indeed there is a bug, how remove_query_arg, removes the parameter we use to add the defer param.

    We will include a fix in the next version. If you give me your site url I will manually patch your plugin.

    Regards,
    Stanimir

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.