Support » Fixing WordPress » Default theme looks great in FireFox, aligned left in IE

  • Default theme (ver 1.5) looks great in FireFox, aligned left in IE.

    Any ideas? I moved my 1.2.2 “Theme” into the carrots folder. If I select it, IE displays correctly but I like the new default theme.

    http://brentandmary.net

    I’ve deleted all the files from the default theme folder and reloaded them from my upgrade downloads folder.

Viewing 13 replies - 1 through 13 (of 13 total)
  • I’m getting closer. I had to replace the align=”left” in my image tags with class=”alignleft”. Now … why are my links being pushed too the bottom? Must have an image too wide under the new theme.

    Ah … I see. FireFox is resizing the images to fit within the width specified by the stylesheet. Is there a way to code the image so IE does that too?

    Not that I know of but I always optimise pics and resize before posting to my blog/website. For my bog I like to stay within 250px -400px but that is me.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    This happened to me after upgrading. Open header.php (Header Template) and look for:
    #header { margin: 0 !important; margin: 0 0 0 1px; padding: 1px; height: 198px; width: 758px;

    Delete the second margin value. It should look like this:
    #header { margin: 0 !important; padding: 1px; height: 198px; width: 758px;

    That’s what worked for me.

    I edited the header.php file but that didn’t do the trick. What should it do when the second margin statement is removed? Does that resize the images or is it suppose to let the content area become wider? Page still looks fine in FireFox.

    http://brentandmary.net

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    It should re-align the content, at least that’s what it did for me. Did you clear your browser cache before double checking?

    Aha! Looks like some temp designers use ffx!

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Funny bit of trivia: The original Kubrick template (which is now the Default theme) contained a gigantic (the biggest I’ve ever seen) “Get Firefox” button if you visited a Kubrick-enabled site in IE. I mean, this button filled the entire post column and took up the length of at least 3-4 paragraphs.

    I seem to be down to 2 choices to get the default theme to work right for me in IE. 1) resize my pics to be under 450 px 2) increase the size of the post content area to 550 px.

    Option 2 seems simple enough but darn if I can get it working right. Can someone hold my hand and show me what I’ll I need to change?

    I would also like to know how to do this, since when I tried it back with WP 1.2.2 the template went ballistic. For those of us who do not wish to standardize our blog for 800×600, and instead would like a larger posting area, what areas specifically need to be edited and how? Thanks!

    I downloaded the mallow them. It’s sized wide enough to accomodate my55opx images.

    Wow is this frustrating. All I want to do is make the default theme’s footer not shift slightly to the left in Internet Exploiter … er I mean Explorer. How on earth does one do that? Help!

    yishay

    (@yishay)

    The bug is caused by the big photos, but if you can’t control their size, because the blog admin doesn’t listen here’s a work-around:
    In wp-content\themes\default/index.php
    add before this line:
    <?php the_content(‘Read the rest of this entry »’);

    the line:
    <div id=”entryframe”>
    and after it add:
    </div>

    Then in style.css add these lines:

    #entryframe {
    width: 450px;
    overflow: hidden;
    }
    It will cut the big photo, but won’t distort everything.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Default theme looks great in FireFox, aligned left in IE’ is closed to new replies.