WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Default template / page template not being picked up

[Resolved] Default template / page template not being picked up

  • Hi,

    I’m having an issue where a page I have created is not picking up the default, it’s picking up a page template for the home page. Even if I create a template for this page it won’t pick it up, but instead picks up the template for the home page. When I edit the page in WordPress, I can see that the template under “Page attributes” is set to “Default template”. Why would it then pick up a template for a completely different page? I am a WordPress beginner so this could be a failure of understanding on my part.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Here are some things that might help you find the answer:

    A template named home.php, index.php, or front-page.php may automatically be used for the home page. This documentation might help: http://codex.wordpress.org/Template_Hierarchy

    Try changing the settings at Settings > Reading > Front page displays, and see if you get different results.

    Your theme might be causing the issue. Try switching to the default Twenty Ten theme and see if you get different results.

    Thanks, that helped. I think the problem was I had home.php for the static homepage, and was trying to set blog as the posts page. blog was picking up home.php even if I included a blog.php. I changed home.php into a template called homepage.php, set the homepage to use that template instead, and Bob’s your uncle, it worked.

    Thanks for the pointer!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Default template / page template not being picked up’ is closed to new replies.
Skip to toolbar