Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Default subscribe to blog is checked

  • Resolved rogerv

    (@rogerv)


    The comment feature is turned on and the checkbox to enable subscription to the blog has been turned on. This once worked properly (default value = unchecked) Suddenly the value is checked as a default. How to I restore the unchecked as default?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor Stef (a11n)

    (@erania-pinnera)

    Hi @rogerv,

    Hmm, that’s unusual. When default features tend to toggle on or off without you doing anything, chances are that there might be something conflicting with Jetpack.

    First off, you can enable the Subscription feature by going to Jetpack → Settings → Discussion. You can read more about that here:

    https://jetpack.com/support/subscriptions/

    If the issue reoccurs, then I’d recommend checking that nothing is clashing with Jetpack. Try temporarily deactivating all your plugins and checking if the problem gets fixes that way. If it works, then reactivate each plugin one by one to find out which one is causing problems.

    Let me know what you find out.

    If you still need help, could you post your site URL here, so I can have a look?
     
    If you want it to remain private, you can also contact us via this contact form:
    Contact Support. Thanks!

    Thread Starter rogerv

    (@rogerv)

    Thanks for the suggestions. Unfortunately, nothing that I tried prevented the “enable subscription” from showing up already checked. If you look at https://voightps.de/contact-us/ you can see the problem.

    (The CSS code to reduce the size of the comment box and the code snippet to remove the URL field were temporarily deleted in following your suggestion to disable everything to see if it took care of the problem – it did not.)

    Plugin Contributor Stef (a11n)

    (@erania-pinnera)

    Hi there, @rogerv,

    I owe you an apology as I misunderstood your initial message, leading you to look at some settings that aren’t really related to the contact form setup you enquired about initially.

    I went to your contact us page and sent a test message (you can delete it while in moderation if you want).

    Upon landing on the page and writing the message, the Notify me of new posts by email. was unchecked, so I suppose that’s the default settings at the moment: https://cloudup.com/co1y0vajO2r

    Is that what you expected? If you see something different, can you try checking the same page on an incognito window or a different browser, to see if the settings are different?

    Thread Starter rogerv

    (@rogerv)

    Hello Stef,
    That was the clue I needed. At some point in my testing, I apparently clicked the box to “Save my name, email and website in this browser …” with the result that the “Notify me of new posts by email” always came up selected. When I deleted the cookies from my site, the box then came up unchecked.

    I would call that a bug. IMO there should be no connection between the two selections.

    Why is the “Save my name …” checkbox not left aligned? And, since I have disabled the website entry (as spam control), how can I change that choice to eliminate the words “…and website”? (happy to start a new topic for these questions if that would be better)

    Plugin Author Karen Attfield

    (@wpkaren)

    Hi @rogerv,

    I can see that that isn’t an ideal flow, having the ‘Notify me’ checkbox auto selected if the ‘Save my name’ checkbox is selected at the same time. I’ve created a Github issue to see if there is anything that can be done from Jetpack’s side at all, feel free to follow along with this if you are interested:

    https://github.com/Automattic/jetpack/issues/19651

    In my testing the ‘save my name’ checkbox only appeared left align, though I realize it wasn’t aligned in the screenshot we sent earlier. If there are any alignment issues these would most likely be the result of a conflict with the theme styling.

    To change the wording, since that checkbox is built in to core WordPress (it isn’t part of Jetpack) we’d be limited in what information we have access to. That said, it looks like there is a suggested solution in this thread:

    https://wordpress.org/support/topic/save-my-name-email-and-website-in-this-browser-for-the-next-time-i-comment-2/

    I hope this information helps!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Default subscribe to blog is checked’ is closed to new replies.