Support » Plugin: Memphis Documents Library » Default Sort Options settings not being obeyed

  • Resolved Cameron Barrett

    (@cameronbarrett)



    This is an ongoing bug that I kept running into. When “Disable User Sort” is unchecked, the settings in Order Types (File Name, Downloads, etc.) and Order Style (Ascending, Descending) are not being obeyed.

    I’ve been able to replicate this bug in several instances of Memphis Docs. In the meantime, checking the “Disable User Sort” checkbox gives me the Sort behavior I want butt hen takes away the user’s ability to sort columns.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author bhaldie

    (@bhaldie)

    Can you describe i detail how to recreate the issue. It would be very helpful in the debugging process. I am have no issue with sort currently but I may be missing something.

    Plugin Author bhaldie

    (@bhaldie)

    This is a cookie issue. When you click on a sort option in the document list a cookie is saved that keeps track of the sort option you have clicked.

    Now if you goto mdocs settings and pick an option like File Name for example and you have selected Last Modified from the frontend, Last Modifed will be the sort option no matter what you have picked as the default value for mDocs.

    Clear you cookie cache and the value you be correct.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Default Sort Options settings not being obeyed’ is closed to new replies.