Support » Plugin: Next Active Directory Integration » Default role not honored – always Subscriber

  • Resolved daretalvitie

    (@daretalvitie)


    ADInx gives my AD-authenticating users the default role Subscriber, even though in Settings -> General “New User Default Role” is something else (a Finnish translation of Author, “Kirjoittaja”). Also implemented: User Role Editor plugin.

    (I could do a workaround and just give Subscriber more permissions, but I’d also like to have Subscriber as a possible role for some users.)

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author FatSquirrel

    (@fatsquirrel)

    Hello daretalvitie

    Thank you for reporting this problem. We will start looking into this bug.
    In the meantime there is a simple fix to your problem:

    ADInx offers a feature that allows you to map your active directory groups to a certain WordPress group.
    For example you could say:
    All active directory users with the group ‘students‘ will have the WordPress group ‘editor‘.

    This should solve your problem.
    To do so, go to your ADInx configuration page and select Permissions.
    Under Role equivalent groups you can set an active directory group and an equivalent WordPress role.

    sample setting
    In this screenshot you can see how we grant all users with the active directory group ‘students‘ the WordPress role ‘editor‘.

    I hope this solves your issue. If you encounter any further problems, please let us know.

    It doesn’t seem to work, maybe because “author” is localized into “Kirjoittaja” (the “WordPress role” dropdown shows roles by their default names – subscriber, author, editor etc). Mapping an ad group into “author” resulted in the testuser getting role “none”.

    Plugin Author FatSquirrel

    (@fatsquirrel)

    When you trigger the Sync to WordPress action, what are does the output look like?
    It should say something like:
    [INFO ] Security groups ["50User","100User","TestGruppeC","Dom\u00e4nen-Benutzer","Benutzer"] are mapped to WordPress roles: ["editor"]

    2016-10-06 09:44:33 [INFO ] NextADInt_Multisite_Configuration_Persistence_BlogConfigurationRepository::persist [line 269] Successfully updated blog option: (1,next_ad_int_bo_v_role_equivalent_groups,group name=author)

    hm, looks like the group “Domain users” isn’t processed at all when the new user joins:

    2016-10-06 09:46:38 [INFO ] NextADInt_Adi_Role_Manager::synchronizeRoles [line 116] Synchronizing roles of WordPress user with ID 138
    2016-10-06 09:46:38 [INFO ] NextADInt_Adi_Role_Manager::synchronizeRoles [line 149] Security groups [“EscapeMembers”,”utu_biologia”,”Pikkutikka TS Users”,”greenroof”,”testgroup”] are mapped to WordPress roles: []

    (The group I’ve mapped Author role to is “Domain users”, but it’s not shown there at all.)

    Plugin Author FatSquirrel

    (@fatsquirrel)

    The same security group that you entered in the Active Directory Integration -> Configuration -> Sync to WordPress -> Import members of security groups should probably be used for the Role equivalent groups setting.

    This way all users you import, should be assigned to the equivalent group you entered.

    Example:
    Import members of security groups : students
    Role equivalent groups: students <> editor

    (All students will then be editor by default)

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Default role not honored – always Subscriber’ is closed to new replies.