Support » Plugin: Web Stories » Default Publish Date to Now

  • Resolved Damien

    (@damienmaurer)


    Hi guys,

    Whenever you work on a story, it feels like the future publish date is defined as the first time you save the draft.
    As a result, if it takes you a week to create a draft (and you forget to change the publish date), it’s published a week in the past.

    Similarly, if you create a duplicate of an existing story, the future publish date is the date of the creation of the copy.

    If you are not in the same timezone as the server, it’s quite hard to know what’s now for the server, so it’d be nice to have an option to just do now – WP posts default to now when you publish a post, even originally drafted a long time ago.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Adam Dunnage

    (@adamdunnage)

    Hello @damienmaurer thanks for getting in touch. I’d be happy to help you with your questions.

    Whenever you work on a story, it feels like the future publish date is defined as the first time you save the draft.
    As a result, if it takes you a week to create a draft (and you forget to change the publish date), it’s published a week in the past.

    Are you referring to the Publish date section in the document tab as seen here? If so, do you mean just the date or the date and time on this?

    Similarly, if you create a duplicate of an existing story, the future publish date is the date of the creation of the copy.

    Is this if you create a duplicate of an existing story and then go to the publishing section to set a date/time?

    If you are not in the same timezone as the server, it’s quite hard to know what’s now for the server, so it’d be nice to have an option to just do now – WP posts default to now when you publish a post, even originally drafted a long time ago.

    Using the publishing section found in the document tab you can set this to publish now or at the time you would like to. This will use the timezone you have set in your WordPress settings.

    If you could provide some step by step instructions on this that would be useful so that we can test exactly how you are. Or you could provide a screen recording using a service such as Loom.

    • This reply was modified 11 months, 2 weeks ago by Adam Dunnage.
    Plugin Support Adam Dunnage

    (@adamdunnage)

    @damienmaurer just to follow on to this I have tested the WP posts publish behaviour with the Web Stories and both behave the same. You should be able to either publish immediately or at a date/time of your choice which if selected defaults to the current date/time set in your WordPress settings. Is this not what you are experiencing?

    Could I ask what your WordPress settings time zone is currently set to?

    When saving a draft the date is always set at “Immediately” until you hit Publish. So even if you only publish after one week the date would still be “Immediately”.

    Thread Starter Damien

    (@damienmaurer)

    Yeah, I’ve retested a couple of stories and it behaves as expected.

    I have no idea why I’ve had a few drafts that had a date set without ever touching it.
    If I can reproduce, I’ll open something 🙂

    Sorry!

    Thread Starter Damien

    (@damienmaurer)

    Actually @adamdunnage, I’ve managed to reproduce the issue. It happens to me pretty much all the time, but I understand it’s not easy to have it if you follow a different workflow.

    Here’s what I did:
    – Clone an existing story
    – Do a bunch of edits
    – Leave it open for the night
    The next day:
    – Continue editing the story and regularly save (everything is fine)
    – Finally, before wanting to publish, edit the Story Description and URL
    => At this point, something strange happens, the Publish button is disabled, Ctrl-S does nothing. However, the date is still showing as “Immediately”

    At this stage, this editor is sort of in limbo, can’t be used anymore.
    So:
    – I open a new tab
    – Paste the URL
    => the whole story was saved up to my very last edits (Story Description & URL)
    => I can now publish (it’s not greyed-out on that tab) – but the date is set to 02/18 (which is when I originally cloned it)

    Note that I use the same workflow on all my sites (leaving stories overnight while I work on them), and this behavior of not being able to save happens almost all the time (maybe it’s when changing the URL?) – which then also triggers the issue with the date.

    I’ll have the Dev Tools open next time to find out if there’s an error response code at some point that causes this.

    Plugin Support Adam Dunnage

    (@adamdunnage)

    @damienmaurer thanks for the update and detailed explanation on this. If you could provide that extra information that would be great and in the meantime I will discuss this with the team and update you as soon as I can.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Default Publish Date to Now’ is closed to new replies.