• Resolved mahyulan

    (@mahyulan)


    When creating the WC default pages from the Status > Tools menu, it creates the pages in the language that was set for the administrator.
    That is wrong as it should be in the site language.

    The language setting for the administrator is just for the convenience of the administrator who is used to work with US-English back-end menu’s.

    The site language is the most important one (in this case Spanish), because that determines what the visitors look at.

    A work-around is to delete the English default pages, set the language for the Admin User to Spanish and then re-generate the pages within the Tools menu.

    In my opinion this is clearly a bug, that I hope will be solved in the next version of WC.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hi @mahyulan

    I understand that your site’s default pages got created in English, but you needed to create those in the site’s language which is Spanish.

    Please note that the pages were created in English because that is the default language, and your site’s language setting seems to have been changed to Spanish later.

    Now that the site language is set to Spanish, please delete the existing default pages, and then install the missing default pages afresh by going to WooCommerce > Status > Tools and use the page installer tool. You may find this document helpful: https://woocommerce.com/document/woocommerce-pages/#install-pages-again

    Please let us know if that solves your problem.

    Thanks

    Thread Starter mahyulan

    (@mahyulan)

    Please note that the pages were created in English because that is the default language, and your site’s language setting seems to have been changed to Spanish later.

    That is not the case. The site has been setup in Spanish from the beginning. After that I installed WooCommerce.
    As you could have read in my comments, it is clearly a bug, because WC gets confused with the language setting of the WP administrator, which obviously has nothing to do with the front-end appearance of WC.

    Mirko P.

    (@rainfallnixfig)

    Hey @mahyulan,

    When creating the WC default pages from the Status > Tools menu, it creates the pages in the language that was set for the administrator. That is wrong as it should be in the site language.

    I’ve tested this and it appears that only the page title is created in the language selected by the administrator. The content of the pages is displayed with the same language used on the site. Isn’t that the case for you?

    If not, you may experience a conflict on your site so following the conflict test guide would be the next step – https://docs.woocommerce.com/document/how-to-test-for-conflicts/.

    Thread Starter mahyulan

    (@mahyulan)

    Hello Mirko,

    Yes, that is what I meant.
    It creates the page titles in the wrong language.
    These should be of course in the language of the site.

    Hi @mahyulan

    Thanks for your confirmation.

    Can you please try Mirko’s suggestion of performing a full conflict test and see if that works?

    Furthermore, in order for us to understand your site properly, can you please share your System Status Report, that will help us further troubleshoot.

    You can find it via WooCommerce > Status. Select Get system report and then Copy for support. Once you’ve done that, you can paste it into your reply here.

    Thread Starter mahyulan

    (@mahyulan)

    Hi Xue,

    Your suggestion and request will not help me much further, I am afraid.

    Mirko was able to exactly recreate the problem, so it has nothing to do with any conflicts whatsoever.
    In my opinion it is just a bug that needs to be solved by the WC development team.

    • This reply was modified 1 year, 10 months ago by mahyulan.

    Hi @mahyulan

    In my opinion it is just a bug that needs to be solved by the WC development team.

    How to file a bug to the development team?

    I understand that you do not believe that the standard procedures of switching off plugins one by one etc. can detect the cause of the problem, and would like to file a bug.

    You can report this on GitHub. The developers use it for issues like this one. You can open up a new bug report here: https://github.com/woocommerce/woocommerce/issues/new/choose
    You’ll want to give them the exact steps to follow to reproduce the issue.

    Thread Starter mahyulan

    (@mahyulan)

    @margaretwporg Thanks lot for your reply. I will do.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Default pages created in wrong language (bug)’ is closed to new replies.