Support » Plugin: Brilliant Geocoder for Gravity Forms » Default map zoom settings, export latitude

  • Hello “Brilliant geocoder” team, your plugin is truly brilliant!
    But to be more perfect, I would like to ask you for a help in a few points:

    a) Is possible to setup a default map zoom on map? Eg. automatic zoom to location entered?

    b) How can I export just latitude and longitude to separate GF field? (maybe it is a dumb question, but currently i am getting some strange results)

    Thank you for your reply and for your plugin!!!
    Kind regards… S.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Same question here 🙂

    Plugin Author Michael Moore

    (@stuporglue)

    a) Is possible to setup a default map zoom on map? Eg. automatic zoom to location entered?

    There’s not a simple way to do it right now. I’ll take a closer look this weekend. I’m working on an updated release and may be able to add some of these controls. If I can’t, I’ll put them in the following release.

    b) How can I export just latitude and longitude to separate GF field? (maybe it is a dumb question, but currently i am getting some strange results)

    The result should be a GeoJSON value. You should be able to get the latitude and longitude as separate values using a Gravity Forms hook.

    Thanks for instant reply Michael!
    I think that zooming/centering on geocoded marker is crucial feature for this plugin.
    I would really have it implemented. Fingers crossed! 😉
    Another option I’m missing is choosing layers for administrator satelite/map/street view for Google.
    BTW: only OpenStreet map automatic marking is working for me – GMaps not at all.

    Since other topic was closed I will write again:

    Hi!
    I can edit script file, no problem.
    But now something new: suddenly I started to got following errors:

    Warning: Illegal string offset ‘OSM Nominatim simple query’ in /wp-content/plugins/brilliant-geocoder-gravity-forms/lib/class-geocoder-gravity-settings.php on line 244

    Warning: Illegal string offset ‘OSM Nominatim full address’ in /wp-content/plugins/brilliant-geocoder-gravity-forms/lib/class-geocoder-gravity-settings.php on line 244

    Warning: Illegal string offset ‘Geocod.io full address’ in /wp-content/plugins/brilliant-geocoder-gravity-forms/lib/class-geocoder-gravity-settings.php on line 244

    Warning: Illegal string offset ‘Geocod.io simple query’ in /wp-content/plugins/brilliant-geocoder-gravity-forms/lib/class-geocoder-gravity-settings.php on line 244

    Warning: Illegal string offset ‘Google Maps API’ in /wp-content/plugins/brilliant-geocoder-gravity-forms/lib/class-geocoder-gravity-settings.php on line 244

    Warning: ksort() expects parameter 1 to be array, string given in /wp-content/plugins/brilliant-geocoder-gravity-forms/lib/class-geocoder-gravity-settings.php on line 247

    Warning: implode(): Invalid arguments passed in /wp-content/plugins/brilliant-geocoder-gravity-forms/lib/class-geocoder-gravity-settings.php on line 251
    It occurs when entering forms settings (newly created too)

  • EDIT 1: Errors above are caused by server PHP version. 7.0 and 7.1 – errors are present, downgraded to 5.6 – errors are gone
  • EDIT 2: script edited and changed from

    success_callback( success );

    to

    success_callback( geojson );

    Unfortunately geocoding works only for “OSM Nominatim simple query”, GMaps are not showing at all 🙁

Plugin Author Michael Moore

(@stuporglue)

@mariuszo, I should’ve had you do this right from the start.

Could you please open a new support request for this issue? Discussion in this support request should be about “Default map zoom settings, export latitude”. Anything else should go in a new request.

You can open a new request here:
https://wordpress.org/support/plugin/brilliant-geocoder-gravity-forms/

Copy and paste your last message for the request and I’ll answer it in the new request.

Thanks,
Michael

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Default map zoom settings, export latitude’ is closed to new replies.