Support » Theme: Tiny Framework » Default Justify Settings

  • Resolved a1vme

    (@a1vme)


    Hello. I am new to WordPress, CSS and website creation and helping a colleague set up a class website. I found the Tiny Framework theme and it is exactly what I was looking for.
    I ran into one small problem and I’m not sure if there’s a setting or an optimal way to correct it.

    Problem: The default Tiny Framework theme settings seem to Justify all text and I prefer to have it left aligned with justify disabled.

    Question: Is there a setting or optimal method to display all text with Justify disabled?

    Thanks in advance,
    Adit Sood

    Note: I added custom css entries – p { text-align: left; } li { text-align: left; } – to get the desired result, but don’t think they will apply to all elements. I’m concerned that, even though it works for now, I’ll need to keep adding custom CSS for other elements as they are added to disable the Justify. I’d like to set it and forget it so I don’t have to revisit or add custom css.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Theme Author Tomas Mackevicius

    (@tomasm)

    Problem: The default Tiny Framework theme settings seem to Justify all text

    This is not true – main post/page text by default is aligned to left.

    a1vme

    (@a1vme)

    Thanks for the reply Tomas. Then I must be doing something wrong because when I take out the custom css, it seems both the main post/page change to justify enabled.

    I have another blog on the same hosting service, Edublogs.org, which is also using your Tiny Framework theme. It doesn’t have any custom css and is using the default Tiny Framework theme settings, but it seems to also Justify the main page and post text.
    If I switch the theme to, say, twenty-fourteen, without changing anything else, the justify seems to be disabled.
    When I’m editing the pages/posts and the Tiny Framework theme is active, it displays the text as Justify enabled; with the Twenty Fourteen theme active, it displays the same text as Justify disabled.
    At this point, I haven’t been able to explain it, but my conclusion was that it was related to the theme settings.
    Can you see if there’s something I’m doing wrong? The url is asood.edublogs.org

    Thanks in advance,
    Adit Sood

    lassial358

    (@lassial358)

    Adit,

    Using Chrome Dev tools you can figure out what’s causing the problem. Inspect the element, under Elements tab, check subtab Computed and filter for text-align

    a1vme

    (@a1vme)

    Hi again Tomas. I followed your suggestion and working with the a blog post (http://asood.edublogs.org/2017/08/23/test-post/), the Inspect Element shows:
    .entry-content, .entry-summary {
    text-align: justify;
    }

    For the front page (http://asood.edublogs.org/), with Inspect Element shows:
    inherited from div.entry-content
    .entry-content, .entry-summary {
    text-align: justify;
    }

    Again from the Inspect Element window, it looks like the value is inherited from the style sheet:
    http://asood.edublogs.org/wp-content/themes/tiny-framework/style.css?ver=2.0.7

    Again, I’m new and learning about the subject, but does this mean the Edublogs CSS style sheet for tiny-framework is setting the Justify?
    Could they be using an older version of tiny-framework and updating would correct the Justify?

    Thanks again for the feedback and help. I appreciate it.
    Adit

    Theme Author Tomas Mackevicius

    (@tomasm)

    I tracked where is the issue. You’re right – Edublogs is using pretty old version of Tiny Framework. Please ask them to update to the latest version. Marking as solved.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Default Justify Settings’ is closed to new replies.