Support » Plugin: All in One SEO – Best WordPress SEO Plugin – Easily Improve SEO Rankings & Increase Traffic » default Facebook and twitter images are not shown when sharing the website link

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support Prabhat

    (@prabhatrai)

    Hi @ghinamt,

    Thanks for reaching out, and I apologize for the inconvenience caused!

    I checked the source of your homepage and found that the Facebook image has been set to https://yasholding.ae/wp-content/uploads/2023/01/yas-112.jpg

    Could you confirm if you’re referring to the above image? If yes, the dimensions of the above image are 112px X 112pxhttps://a.supportally.com/i/zyUz82

    Facebook supports images with dimensions of at least 200px X 200px and recommends using images of 1200px X 630px.

    Also, I tested your website using Facebook’s Debugger Tool (https://developers.facebook.com/tools/debug/?q=https%3A%2F%2Fyasholding.ae), and an SSL-related warning is shown. Here’s a screenshot for a quick reference – https://a.supportally.com/i/ADW6BZ

    Please update the image with the above-recommended dimensions and reach out to your hosting provider regarding the SSL issue, as they would be able to investigate and fix it.

    Once done, clear your website & browser’s cache and test the website again using the above tool to see if the image is shown.

    You would need to click the Scrape Again button for Facebook to crawl your website again and see the changes – https://a.supportally.com/i/gnZvAJ

    Please feel free to let me know if you have any questions.

    Thanks!

    Thread Starter ghinamt

    (@ghinamt)

    @prabhatrai , yes you are right the used image is: yas-112.jpg

    but now I changes it to “yas-512.jpg” with 512×512 pixcel dimintions, but the issue is still presented on both FB and Twitter… also the meta title and description is displayed correctly as I set it inside the website.

    highly appreciate your quick feedback.


    Plugin Support Prabhat

    (@prabhatrai)

    Hi @ghinamt,

    As mentioned in my previous reply, an SSL Certificate warning is shown in the Facebook Debugger tool for your website – https://a.supportally.com/i/ADW6BZ

    I tested your website using https://httpstatus.io/, and a similar error is shown – https://a.supportally.com/i/TSt6jn

    This is likely causing the issue here.

    Please reach out to your hosting provider regarding this, as they would be able to investigate and fix the SSL issue on your website.

    Once done, clear your website, server & browser’s cache and test the website again on Facebook/Twitter, and see if the image is shown.

    Please let me know how that goes.

    Thanks!

    Plugin Support Steve M

    (@wpsmort)

    Hi @ghinamt,

    We haven’t heard back from you in a couple of days. I’m going to go ahead and close this thread for now. But if you’d like us to assist, please feel welcome to continue the conversation.

    Thanks!

    Thread Starter ghinamt

    (@ghinamt)

    @prabhatrai @wpsmort thanks for your prompt and fast feedback, the issue is solved, it was ssl related issue.

    can you please help me in deleting the above images please, as it is contains site name which I would not like it to be shown “I just noticed that and there is no option to edit it.”

    Plugin Support Prabhat

    (@prabhatrai)

    Hi @ghinamt,

    I’m glad that the issue got fixed!

    Unfortunately, we do not have the authority to remove images from the replies.

    Also, WordPress.org support forum tickets/replies can only be edited within 60 minutes of posting them –

    https://wordpress.org/support/forum-user-guide/faq/#how-can-i-fix-typos

    As your reply is not within the edit window, you would need to contact the WordPress.org forum moderators for removing the images.

    https://wordpress.org/support/guidelines/#contacting-the-moderators

    Please let me know if you have any questions.

    Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘default Facebook and twitter images are not shown when sharing the website link’ is closed to new replies.