• Resolved expedient

    (@expedient)


    See link. The default date/time offset is not working.
    I’ve tried it with various post types, different values for the offset even on another environment. When setting the date manually it does work and is properly removed by the cron job. So its just the offset that is not working.

    The video is in an environment with all other plugins disabled.
    In the video the offset should be 1 month, but it sets the date the same as the creation date instead of with a 1 month offset.
    Latest WP version and plugin version. Tried PHP Version: 8.2.4 and 8.1.17

    • This topic was modified 1 year ago by expedient.
    • This topic was modified 1 year ago by expedient.
    • This topic was modified 1 year ago by expedient.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Riza Maulana Ardiyanto

    (@rizaardiyanto)

    Hi @expedient

    It seems I cannot replicate it. Please see this video where I start from clean WordPress installation: https://www.loom.com/share/0f09ded899b44ae993a3a3dab3398863

    Thanks,

    Thread Starter expedient

    (@expedient)

    Hi @rizaardiyanto,

    I’ve set up a clean wordpress installation and tried the steps in your video.
    The problem still persists. If you have an emailadress for me I can send you the login details of this clean installation enviroment.

    Kind regards,

    Plugin Support Riza Maulana Ardiyanto

    (@rizaardiyanto)

    @expedient Troubleshooting directly in the site is a premium support for our pro users.

    If you insist to use free support, do you mind sharing some screen recordings of how you reproduce this issue in a clean WordPress installation?

    Thread Starter expedient

    (@expedient)

    Hi, Tried it with a fresh install, see:
    https://www.loom.com/share/0c96d9b28c414f36b25a91469cb6c335

    What I noticed:
    ‘Default date/time offset’ works when ‘Auto-enable?’ is disabled.
    When ‘Auto-enable?’ is enabled the ‘Default date/time offset’ does not work. See the video.

    Plugin Support Riza Maulana Ardiyanto

    (@rizaardiyanto)

    If you enable “Auto-enable” you need to define the default offset time on that post type. Check this image:

    Thread Starter expedient

    (@expedient)

    Figured it out:
    When the default date/time offset is set as a default in the Defaults tab, for example +1 week, it is also shown like that for posts in the Post Types tab as a placeholder in that field, which gives the impression that the default will be used when nothing is filled.

    The default however is only used when auto-enable is disabled. When auto-enable is enabled it does not use the default tab set ‘default date/time offset’ (even though it still shows it as a placeholder), but it needs to be set manually.

    I do wonder if this is either odd UI design with no proper explanation or indeed a bug.

    Plugin Support Riza Maulana Ardiyanto

    (@rizaardiyanto)

    I do see a space for improvement. Thank you for the feedback.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Default date/time offset not working (with video)’ is closed to new replies.