Support » Fixing WordPress » Default category not displayed // Can’t delete cat id=1 // Can’t delete cache

  • Resolved Dustyakubra


    I just upgraded to wordpress 2.0.1.
    My theme is Fluidityrs 1.0
    The code
    <?php list_cats(0, '', 'name', 'asc', '', 1, 0, 1, 1, 1, 1, 0,'','','','','') ?>
    which is in my sidebar – is not showing my default category – help? why not? *breaks down into a mess of sobbing*

    I thought I’d try solving this by creating a new category, making the new one the default, and then deleting the old default one, so that all the posts would be transferred to the new default one. However, even though it says the new category is the default one, when I attempt to delete the old one, it says that that one cannot be deleted because it is the default.. help?

    I searched around the forums, and somebody suggested deleting /wp-content/cache/ – I tried to do that through ftp but i get 550 errors “Permission denied”

    Any help would be much appreciated!

Viewing 9 replies - 1 through 9 (of 9 total)
  • I think the way to fix this it to make a test post in the new default category – I did a lot of other fiddlign (I’ll explain in a sec) but I think that’s what fixed it.

    What I did:
    I used myphpadmin to delete the old default category, then creating a new category called the same thing – this is now the 3rd category (I have more categories on my site, but just in terms of ones i’ve been referring to with regard to this problem.)

    So now I set the new category (3) to default, and then delete category 2. Then I make a test post in the new category, and finally it shows up!

    Very ugly, but a solution I suppose.

    No category will ever show up until it has posts – unless you’re tweaking the display specs in core code.

    Oh but it did have posts in it. It just didn’t quite register that I’d moved them from one category to another.

    Ah…. well, at least it’s fixed, which is after all the important thing!

    I’m having the same problem as in the first post. My category 1 (no longer the default btw) while it has two posts in it, isn’t displayed in list_cats. I have view the archive of that category though…

    why wouldn’t it show up in the category list?

    rustin: try making a new post in that category.

    Did you just upgrade to 2.0.1 like me?

    There are actually 2 posts currently in that category and it still doesn’t show up.

    I did just upgrade to 2.0.1, but it was happening in 2.0 as well.

    Yes I know, I had posts in my category too, but try making another one.

    HEY! It worked. If I make one new post, it shows up in the category list. Odd

    Thanks Dustyakubra

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Default category not displayed // Can’t delete cat id=1 // Can’t delete cache’ is closed to new replies.