Support » Plugin: Restaurant Reservations » Default Booking Page Setting is Overriding the display of the Shortcode

  • Hey there, thank you so much for your really wonderful plugin. It has been a lot of help and works great. I only have one issue so far. I recently ran into an issue with it trying to redirect to a thank you page. I have been using the redirection code you provided. That works perfectly but about a week ago, I had been testing my reservation page and I found out the form was not working. The reason was that it was redirecting to a broken link. I found out it was because I had trashed a test booking page I had created to test the plugin on. I didn’t know why it was redirecting to that page before going to the thank you page. I had used the correct ID for my thank you page on the redirection code. I also use a redirection plugin for site that manages broken links and 301 redirects. I disabled that plugin but still had the form redirecting to the test booking page before redirecting to the thank you page. I finally found that I had my test booking page as the default Booking Page in the General Settings. I changed it to the Reservation page but now I have a different problem.

    Previously I had been using the shortcode to display the form inside a column with some text above and some below. After setting the Reservations page as the default Booking Page, the form now displays at the very bottom of the page. And it also takes the full width of the page. The page no longer looks as good as it used to even though it’s still working. I have deleted the plugin and reinstalled it again hoping that the default Booking Page setting would be empty. However, all the settings remained the same so I no longer know what to do. I would really appreciate some help. Is there any way I can make the shortcode take precedence so that it displays inside the column?

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Hi, just try to disable it. If you use the shortcode then disable the default page. Leave it blank. In that case you can tune your page with the shortcode anywhere you want it.

    • This reply was modified 1 month, 1 week ago by  drrob67.
    • This reply was modified 1 month, 1 week ago by  drrob67.
Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.