Support » Fixing WordPress » Default Avatar doesn’t follow admin setting

  • I set my default avatar (for those users that don’t have an avatar) to be the mystery man but for some reason the Gravatar logo is being used as the default avatar. I’ve tried clearing my cache but it still puts new users w/ no avatar as the Gravatar logo. Any ideas would be greatly appreciated!


Viewing 1 replies (of 1 total)
  • Steve


    Hi Brian,

    Depending on your theme you need to update either your comments.php or your functions.php file and remove the $default= part. Change

    <?php echo get_avatar($comment, $size=’40’, $default='<path_to_url>’ ); ?>


    <?php echo get_avatar( $comment, $size = ’40’ ); ?>

    Hope that helps.

Viewing 1 replies (of 1 total)
  • The topic ‘Default Avatar doesn’t follow admin setting’ is closed to new replies.