Support » Fixing WordPress » Default author on multi-author blog

  • Resolved TrishaM


    I manage a multi-author blog, but have noticed when I write a new post or page while logged in as the admin, the post/page author name defaults to the first in the [alphabetically sorted] list, even though I have my name (trisha) set for my admin login.

    It behaves as expected if logged in as any other user – the post/page author defaults to the logged in user. This only happens when logged in as admin.

    Is there a way to change the default author while logged in as admin?

Viewing 13 replies - 1 through 13 (of 13 total)
  • You can edit them back by going Posts – Edit – scrolling down and changing Post Author. This option used to be on the Add New page too, but I seem to have lost it in 2.7.1!?!

    Hmmm, wait for some more opinions as I might be missing something too.

    Aha, as soon as the post gets saved as a draft you can change the post author by scrolling down and finding the menu.

    I’ve created some dummy users on an installation of mine and it picks “Ben” over “A Test” when I create posts (as admin). Check your Post Author option for every post – it might be remembering your last choice?

    Thanks Ben for the suggestions…. perhaps I worded my question incorrectly.

    I DO scroll down and change the post author, I’m just getting tired of having to remember to do that every time, otherwise posts or pages get published showing the wrong author, since my author list seems to default to alphabetical order, and there are a large number of authors on my list before it gets to “Trisha”…it just always shows the first author in the list.

    Since I log in as “admin”, it seems like WP should know to automatically default to the Display Name I have set in the admin user profile, which is ‘Trisha’. It does default to the correct display name for any other user, just not for admin user.

    Yes – it should find your name correctly. From my test it doesn’t seem to be to be a bug in WordPress. You could try updating to WordPress 2.7.1 and see if that rectifies the error?

    Hoping that maybe someone will have come across a fix for this – I have upgraded to 2.7.1 and it’s still a problem.

    To recap, and not waste anyone’s time:

    If logged in as ANY user EXCEPT admin, the post author defaults to the correct display name for whomever is logged in;

    If logged in as ADMIN user (only) then the post author defaults to the FIRST name in the list which is sorted alphabetically, instead of to the display name for the Admin user, so the admin user has to remember to scroll all the way down to the bottom of the page and CHOOSE the correct author display name from the list, else the post publishes with an incorrect author name.

    I have tested this using numerous browsers/computers and it’s always the same – problem is ONLY with Admin user – it’s almost like WP thinks the Admin user doesn’t write posts so it doesn’t bother to choose the correct display name for the author.

    I have something better than that. I’m having the same thing happen as described here, but with one additional twist. When I scroll down in a post I’ve just created to try and correct the Author by selecting ‘admin’ from the list of Authors, ‘admin’ is not listed among the authors (only those I created and set up as Authors are listed). It’s almost like ‘admin’ doesn’t exist–even though I am logged in as admin. So, even scrolling down to the various Authors, I still can’t correct the problem. I’m now scratching my head, wondering if a file has gotten corrupted somewhere…?

    My sister’s WP blog had a similar problem. There are three admin users. She was writing the post using her admin user. But when she tried to update the Post Author field, she could only select my admin user or the other admin user.

    I was able to force her to be the author by temporarily changing her user to be an editor, and then updating the post author for her. Then, when I set her user back to an admin she stayed the author. Very strange…

    I am running 2.9 and have the same problem that dbinbama and gdinsmore have. Admin does not show up in the drop-down. I have to log in as another user to post or it will chose the first user in the list for Admin. I tried changing the roles of the other users just for fun. No change. Admin is not able to be selected as author for any posts.

    Mayhap a bug that’s been missed? I’ll see about beating on it a bit more to see if there’s a way to CAUSE it (set up a fresh blog and try to replicate). If I get anywhere I’ll enter a TRAC ticket or post what I find if anything.

    This is happening to me as well when logged in as admin (2.9.1)… seriously annoying and lame… admin can’t post or even pick his/her name from author list?

    I am having the same problem. When logged in as the admin, my user name does not appear to select as the author — only the 2 other authors are listed. Originally this was not a problem because I have other posts with me as the author. I just noticed it yesterday. There has to be a solution.

    Just for the record, I have the same problem as derker on various blogs and versions up to 2.9.2. Had to give myself another username to be an author.

    Thanks MichaelH, first method worked for me.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Default author on multi-author blog’ is closed to new replies.