Support » Plugin: WooCommerce Show Attributes » Default Attributes Tab Not Showing

  • The default attributes tab is not showing on Simple products as expected when the plugin is enabled. We want to use the plugin for showing attributes in the cart and order data, but not change anything about the default behaviors in WooCommerce for Single Product Pages. The expected behavior is to see the “Additional Information” or “attributes” tab in the normal tabs section beneath the product description area. The only way we can get it to show is to set the product to “variable product” and check at least 1 attribute as “used for variations” – otherwise the tab is hidden for all Simple products. Can this be enabled?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Still wondering if this plugin can be used without losing the normal attributes tab on “Simple Products” or not… ?

    I think it’s some kind of plugin bug. The plugin seems to reset the options for displaying product details.
    For my part, I reactivated the details in “woocommerce / setting / general / Product Details” and everything works again

    Hi,

    Thanks for your response.

    Could you specify where this setting is or take a screenshot? I don’t seem to have any settings under WooCommerce > Settings > General that are named “Product Details” and there’s no settings with any values called “Product Details”…

    Found a fix. Open this file located in:

    wp-content/plugins/woocommerce-show-attributes/woocommerce-show-attributes.php

    comment out line 41 by adding two backslashes at the start of the line:

    // add_filter( 'woocommerce_product_tabs', array( $this, 'additional_info_tab' ), 98 );

    Save then go into Woocommerce > Settings > Products > Show Attributes and uncheck Show Attributes on Product Page. It’s not an ideal solution since updating this plugin will erase this edit but it gets the job done.

    • This reply was modified 2 months, 3 weeks ago by jasonmares.
Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.