Support » Plugin: SEO Ultimate » Deeplink Juggernaut – Settings don't save anymore

  • Resolved sonnybonds


    I cannot add deeplinks or footerlinks anymore.
    I have 141 deeplinks working.
    If I add 1 more the settings boxes and # values on the 2nd tab “content settings page” are cleared. When I mark the boxes (any) again and hit save I get the message “updated” but the checked boxes are not remmebered.
    So posts, pages and media are not marked and therefore deeplinks are not working.
    It doesn’t matter which link i add : f.i. the word “google” link to “” – as easy as it gets. I tried several.
    When I remove the freshly added deeplink I can mark the boxes again and they are saved and deeplinks are working again.
    I can now only add a new deeplink if I remove an older one (then the save settings works). It seems that I have reached a limit, but I read somewhere that there’s no maximum.
    I can also not mark “media” in the settings. It is not remembered, never.
    Also other checkboxes under Self linking and Quatity restrictions are NEVER remembered.
    I have the same functionality problem with footerlinks: after 25 or so it just stops adding new ones. And even now my 5 last footerlinks have vanished and I cannot ad new or save footer link settings.
    I use a link cloaking plugin.
    I don’t use categories or sitelinks.
    I tried de-activate + activate again.
    I tried reinstall.
    All links are marked nofollow and new blank window.
    I did not try reset (yet) in fear of losing my work…
    I use WP 3.4.2 and SEO ultimate 7.5.7
    I have a multisite setup. It does work on other similar sites with same plugins, theme, and lots of same outgoing links.
    Any idea’s ?

Viewing 14 replies - 1 through 14 (of 14 total)
  • Update : I exported my deeplinks, reset seo ultimate and tried to import again. All deeplink lines were blank. ๐Ÿ™
    I removed an anchor text and title attribute in the csv file that contained a special character : an o with 2 dots on : รถ
    Now I could import the links again.
    The above problem seems to be solved. However I had to export-reset-import.
    I could not just remove the deeplink with the special character in the deeplink juggernaut link list page.
    Still anyone any ideas before wiping this issue as solved from the table. It might show up again, and maybe the special character was not the issue. I did reset, so maybe an unknow isue bas also deleted…
    All the links were marked as no-follow, could this also be initiating the problem?

    Update: all the no follow boxes are not marked on the imported deeplinks. I marked all 140 1 by one and saved. The problem is here again. When I add a deeplink the settings are removed ๐Ÿ™
    I dit the export-rest-import procedure again.
    I can now add new deeplinks. But when I check the no follow boxes the problem comes back.
    All the open in new window boxes are also marked, no problem with that.
    So it seems that the system cannot handle so many no-follow attributes.

    I have the same problem.

    After having recognized that there are no automatic links within my posts anymore I checked the settings of Juggernaut.

    I am using the latest version of Juggernaut (within SEO Ultimate 7.6.1) and deselected the option “Donโ€™t link the same anchor text any more than 1 times per post/page/etc.” today. From that point on every tick box was de-selected and stays that way even after activating anything and hitting save.

    I don’t know whether this appeared after an update or the switch to a new domain. If the last where would I have to customize the plugin to work again. If not the last, what else?

    Thanks a lot for helping out.

    Plugin Author Jeffrey L. Smith



    1) If you moved to new domain and did not export and reimport links this could have been the issue since autolinks are database dependent.

    2)Try seeing if your link dampening is on, if so set it to 90 or 100 (if you want 100% of the links to be autolinks).

    3) Regarding this “I am using the latest version of Juggernaut (within SEO Ultimate 7.6.1) and deselected the option “Donโ€™t link the same anchor text any more than 1 times per post/page/etc.” today. From that point on every tick box was de-selected and stays that way even after activating anything and hitting save”. Not sure about this one, we can open a ticket on this issue to test locally.

    Try adding 2 times per page and see if this fixes the array.

    4) Try adding new links in content link settings to see if your links appear there.

    I await your reply.

    Thanks for the fast reply, Jeffrey.

    1) Yeah, I did just that. I didn’t know how to export and reimport links. But I just a wordpress plugin for the domain change that should’ve re-written the database entries and replaced them with the new domain. But that doesn’t seem to have done the trick.

    Can I do that now somehow?

    2) No, it wasn’t on as no checkbox is ticked right now and unfortunately still can’t get ticked.

    3) With locally you mean in my wordpress account (with a guest admin account) or on your machines? That could be a solution. What information would you need from me?

    2 times a link per page unfortunately doesn’t work (see 2) either.

    4) Strangely it worked with one new link in this section but I couldn’t add another one.

    I could record a little screencast to show you what I do. And although my wp-version is in German you should be able to figure it out. Or I could give you a test account. Since I trust you I wouldn’t mind at all.


    Good morning Jeffrey,

    I’d be happy for an answer and hope, you can give one again. ๐Ÿ™‚
    Thanks in advance and have a good week.


    Plugin Author Jeffrey L. Smith



    In reference for #2, try updating to version 7.6.1 first off, as this (bot saving checkbox toggle) was addressed in a bugfix.

    Plugin Author Jeffrey L. Smith


    My apology, I mixed up the question with another response.

    I think you have a caching issue. You may have to start fresh by deleting your deeplinks and entering them again since your migration from another domain to the new one did not work.

    Also, not sure which plugin you used, but they may not play well together and hence the disarray.

    1. Export the links and you can replace them with page or post ID or absolute URLS.

    2. Personally, I use
    [x] Donโ€™t link the same anchor text any more than 1 time per post/page/etc.

    and try the dampening effect [x] Additional Dampening Effect
    Globally decrease autolinking frequency by 50%

    Read this post on how it works –

    3. I was talking about is locally working on a machine to test, but invariably our conditions are not the same as yours.

    If dormant data is in the database from before (before the domain name change), this could be why new data is not being saved. You may have to purge links and try again or map out in excel file and then import.

    Let me know if this helps.

    Hey Jeffrey,

    thanks for your reply.

    We’re getting closer. ๐Ÿ™‚

    1) I exported the config and the (old) links.
    2) I deleted all the (old) links.
    3) I ticked the boxes we mentioned in the config (all in section Quantity Restrictions with numbers 1, 1 and 5) and the Globally decrease autolinking frequency by 50%.
    4) saving works now
    5) adding new links works, too

    All that is left and that doesn’t work yet: Importing the old file again.

    I don’t know if it’s the “Umlauts” in the csv file (UTF-8) or anything else but I can’t get it to work just yet. ๐Ÿ™
    Any idea?

    Really appriciating your help,

    Plugin Author Jeffrey L. Smith


    not sure why CSV import would not work… How many links did you have (you may have to start fresh) or map them on spreadsheet and import using absolute urls (instead of post Id’s).

    Is there a fast way to do it? A plugin with export function? A database export?

    If searching every title for every number is the only way I’d rather type in all the keywords again single handedly… ๐Ÿ™

    I googled it but couldn’t find any helpful way to do it.
    Thanks for your help in advance!

    I did another try with importing the cvs. I deleted some quotation marks that were still there, imported the file and had some lines with e.g.

    my keyword – posttype_post – 3214

    I deleted those lines (unfortunately I couldn’t figure out a pattern), went to the content link settings, ticked the above mentioned boxes and voilร  – it worked could be saved.

    I hope new entries will be saved as well and everything will work out as planned…

    Plugin Author Jeffrey L. Smith


    Awesome Micha:

    Glad this is resolved. All the best!


    Sorry, I have to reopen this topic. ๐Ÿ™

    Again I cannot save the settings.
    After having swiped the keywords/anchors from “content links”, I could tick and save the options under “content link settings”.

    The options stayed the same after adding some “anchor texts” and “destinations”.
    But after a new import of the old keywords/anchors, the content links settings again disappeared and cannot be changed and saved anymore.

    Even after adding some keywords within the article (SEO Settings -> Links -> one link per line) the content links seem to be broken (see attached screenshot).

    1) cleaning the database and adding anchor texts over the “content links” fields seems to work
    2) importing my old database (see attached csv) doesn’t work
    3) typing in links within the article doesn’t seem to work properly either. ๐Ÿ™

    Here are the sample files:
    The used article is

    Using Chrome Version 31.0.1650.57
    OSX 10.9


Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Deeplink Juggernaut – Settings don't save anymore’ is closed to new replies.