WordPress.org

Forums

Amazon Link
[resolved] Deep links title does not change (6 posts)

  1. Wavinemba
    Member
    Posted 1 year ago #

    Hi,

    First of all congratulations for this plugin. In my opinion it is amazing! Thank you so much for creating it. It is very helpful!

    The thing is that I have a problem (I think it is a bug in fact) inserting deep links (affiliate links along the text body of an article). To create one, I fill the ASIN field, write the title for the link ("Amazon" is the word for default in this field, but I change it for each deep link), and then I choose the channel. I leave blank the template, as it is the way that works for creating deep links (just an affiliate link in the text, no images, no nothing).

    The problem is that once the link is created and saved, the title field keeps the word that comes for default: "Amazon". And if I delete it on the Plugin Settings and leave it blank nothing is displayed on the title as the words saved on the title field are not being saved. I think this is a bug. Could you please help me? I leave you a link to one test post with screenshots in case you can have a look.

    Thank you a lot in advance!

    https://wordpress.org/plugins/amazon-link/

  2. paulstuttard
    Member
    Plugin Author

    Posted 1 year ago #

    You are right it is a bug, thanks for spotting it!

    I will fix it in the next version of the plugin.

    In the short term you can manually change the link text by finding the shortcode that you have just entered into the post content, e.g.:

    [amazon asin=B008DF57GQ&channel=default]

    and adding the 'text' argument:

    [amazon asin=B008DF57GQ&text=Xperia]

    (Also if you only ever use the default channel, you do not need to specify this as it will do this automatically).

    Paul

  3. Wavinemba
    Member
    Posted 1 year ago #

    Thank you very much, Paul! I really appreciate your help! And in the meantime, I will do as you say, inserting the text argument manually. Thank you so much for your support and great job!

  4. paulstuttard
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    I've found the offending lines of code and the next version should work as before. I'll try and get an update out this week.

    Cheers,

    Paul

  5. Wavinemba
    Member
    Posted 1 year ago #

    Wow!!! Thanks!!! :-))

  6. paulstuttard
    Member
    Plugin Author

    Posted 1 year ago #

    The latest version (3.2.2) - should now be working as it should,

    Cheers,
    Paul

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Amazon Link
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.