Support » Plugin: Query Multiple Taxonomies » Declaration standards error

  • Hi,

    I’m getting this error upon activating the plugin:

    Strict Standards: Declaration of Taxonomy_Drill_Down_Widget::init() should be compatible with scbWidget::init($class, $file = ”, $base = ”) in C:\inetpub\wwwroot\help\Dev\wp-content\plugins\query-multiple-taxonomies\widget.php on line 247

    Any idea what might be causing this?

    Thanks,
    Trish

    https://wordpress.org/plugins/query-multiple-taxonomies/

Viewing 1 replies (of 1 total)
  • I’m no expert with OOP but after doing a bit of research on declaration standards errors and reading this article I managed to remove the error message. See solution below…

    Parent Class
    ——————————————————-
    located: plugins/query-multiple-taxonomies/scb/widget.php

    Change line 10 to…
    static function init( $class, $file, $base ) {

    Child class
    ——————————————————-
    located: plugins/query-multiple-taxonomies/widget.php

    Change line 11 to…
    static function init( $class, $file = “”, $base = “” ) {

Viewing 1 replies (of 1 total)
  • The topic ‘Declaration standards error’ is closed to new replies.