Support » Plugin: Advanced AJAX Product Filters » Debug error

  • Resolved MagineM



    I’m getting the following error on my site when I turn on DEBUG mode:

    Hook was called incorrectly. Only a static class method or function can be used in an uninstall hook. Please see Debugging in WordPress for more information. (This message was added in version 3.1.0.) in /wp-includes/functions.php on line 4773 Warning: Cannot modify header information – headers already sent by (output started at /wp-includes/functions.php:4773) in /wp-admin/includes/misc.php on line 1196 Warning: session_start(): Cannot start session when headers already sent in /wp-content/plugins/woocommerce-ajax-filters/includes/custom_post.php on line 206


    Headers already sent in /wp-includes/functions.php on line 4773.
    This is not a good sign, it may just be a poorly written plugin but Headers should not have been sent at this point.
    Check the code in the above mentioned file to fix this problem.

    • This topic was modified 4 months, 1 week ago by MagineM.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Dima Holovnia



    On line 206 we have

    if ( ! session_id() ) {

    So we are not sending the headers. And on the point where we are asking to start session header shouldn’t be sent yet. So you need to dig dipper.

    Try to install plugin Query Monitor. Maybe it will show you what plugin/file is sending and what content. Would be easier to find.


    Plugin Author Dima Holovnia


    And btw

    1. Please update plugin to the most recent version of the plugin. The issue is fixed there.

    2. Please open plugin settings page tab Javascript and clear field custom CSS. Save settings

    3. Please check if you have user systemusers. If yes – remove it.


    Hi Dima,

    Thank you for the feedback. I think I have found the issue and it was another plugin mail logging plugin interfering here. Deactivated and don’t get the error anymore. 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.