WordPress.org

Forums

NS Cloner - Site Copier
[resolved] Debug error (2 posts)

  1. Jeff Smith
    Member
    Posted 2 years ago #

    Love the plugin. I use it everyday! I was doing some debugging on a site today and saw this:

    Notice: session_start() [function.session-start]: ps_files_cleanup_dir: opendir(/var/lib/php5) failed: Permission denied (13) in /nas/wp/www/staging/orderstrip/wp-content/plugins/ns-cloner-site-copier/ns-cloner.php on line 77

    Ever seen this before?

    http://wordpress.org/plugins/ns-cloner-site-copier/

  2. Never Settle
    Member
    Plugin Author

    Posted 2 years ago #

    Interesting, no haven't seen that before with the Cloner, but have seen it in other cases. This almost always means that you don't have write permissions on the directory that PHP is configured to use as its session save path (or it just doesn't exist). Usually this is /tmp but different hosts have different default setups.

    A couple possibilities:

    1) Make sure that /tmp exists under your main root (probably same level as public_html) and that the owner has write permissions. Permissions should probably be 755.

    2) And/or you might have to check your PHP ini or check with your host as to where the session save path is configured and make sure that PHP has permissions to write to it.

    Hope that gets you there! Let us know!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • NS Cloner - Site Copier
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.