Support » Plugin: NextScripts: Social Networks Auto-Poster » Debian + php7.0-fpm = curl not recognized

  • Resolved Vidyut

    (@vidyut)


    The plugin shows an error that curl is not there on Debian stretch + Nginx + php7.0-fpm. Curl is installed and showing on phpinfo()

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author NextScripts

    (@nextscripts)

    Sorry, but you need to talk to your server admin or hosting provider.

    Plugin foes a very simple check for curl. It checks for availability of the function curl_init (http://php.net/manual/en/function.curl-init.php).

    Literally this is all the code:

    if (!function_exists('curl_init')) die('Error: No cUrl');

    This is the result of the test function provided by you

    Testting... cURL
    Ver: 3.8.7
    
    Deflate - Yes
    
    --== Test Requested ... https://www.nextscripts.com/
    
    Fatal error: Uncaught Error: Call to undefined function curl_init() in /root/to/site/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/nxs_functions.php:753 Stack trace: #0 /root/to/site/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/NextScripts_SNAP.php(39): nxs_cURLTest('https://www.nex...', 'HTTPS to NXS', 'Social Networks') #1 /root/to/site/wp-settings.php(303): include_once('/root/to/site/wp-...') #2 /root/to/site/wp-config.php(95): require_once('/root/to/site/wp-...') #3 /root/to/site/wp-load.php(37): require_once('/root/to/site/wp-...') #4 /root/to/site/wp-admin/admin.php(31): require_once('/root/to/site/wp-...') #5 /root/to/site/wp-admin/options-general.php(10): require_once('/root/to/site/wp-...') #6 {main} thrown in /root/to/site/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/nxs_functions.php on line 753
    Plugin Author NextScripts

    (@nextscripts)

    This is exactly what I told you. You don’t have function curl_init. It means you don’t have cURL configured with PHP. SNAP can’t work without cURL.

    My apologies. Curl was indeed installed, but there was some conflict preventing it from working. Fixed. This issue is closed. In case it helps anyone, here’s a quick and dirty fix I used to get rid of the “curl: symbol lookup error: /usr/lib/x86_64-linux-gnu/libcurl.so.4: undefined symbol….” nightmare that can prevent curl from working.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Debian + php7.0-fpm = curl not recognized’ is closed to new replies.