Support » Plugin: WP WooCommerce Mailchimp » Dealing with PHP 5.4 Warning in CentOS 6

  • We are receiving the warning “WooCommerce MailChimp requires PHP Version 5.4.0 or newer. You’re using Version 5.3.3. Please ask your host to upgrade your server’s PHP.” in the admin. However, we run CentOS 6, which is locked on PHP 5.3.3 but adheres to RedHat’s Security Backporting policy ( ).

    So, is this warning for security reasons (in which case, irrelevant to us), or are there some features of PHP 5.4+ that our 5.3.3 implementation will miss?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Adam Anderly


    Yes, just for security reasons. The plugin should still work, but you will see the warning message.

    Thanks, Adam. Given that PHP < 5.4 is not a security problem when running a system that does security backporting (e.g. CentOS, RHEL), is there an easy way that we can disable this?

    For example, could you change includes/class-ss-wc-mailchimp-plugin.php to:

    `308 // Minimum supported version of PHP
    309 if (defined(‘RHEL_BACKPORTING’) && RHEL_BACKPORTING === true) {
    310 $this->define( ‘SS_WC_MAILCHIMP_MIN_PHP_VERSION’, ‘5.3.3’ );
    311 } else {
    312 $this->define( ‘SS_WC_MAILCHIMP_MIN_PHP_VERSION’, ‘5.4.0’ );
    313 }`

    this would at least allow us to do e.g. define('RHEL_BACKPORTING', true) in wp-config.php

    Any further thoughts on supporting a way to disable this unnecessary message for Linux distributions that support security back-porting?

    Plugin Author Adam Anderly



    I’ll look at making this warning “dismissable” so that you dismiss the warning and not see it for awhile.



    Thanks, Adam. That would be a big help! 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Dealing with PHP 5.4 Warning in CentOS 6’ is closed to new replies.