Support » Plugin: All-in-One WP Migration » Deactivating the plugin crashes my web site

  • Resolved shakarum

    (@shakarum)


    Hi

    So this issue happened to me in two different websites, each in a separate hosting company –
    Plugin works without any issues. However, when I try to deactivate it, then my website crashes. The only way to return to normal is by manually activating the plugin through phpmyadmin -> wp_options -> ‘active plugins’ table (which took me a long time to figure out).

    Why is this happening? How can I remove the plugin totally without breaking my site?

    Thanks

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author Yani Iliev

    (@yaniiliev)

    @shakarum

    There is something else, not related to the plugin that breaks the website.
    Enable WP_DEBUG to true in wp-config.php, refresh the site and see what happens.
    Also disable caching if you have any.

    Not sure what was that supposed to do, but anyway I changed that to “true” and problem remains.
    Don’t have any caching plugin.
    Thanks

    Listen, I really need your assistance here.
    I have issues with something else in my website and as always, as a first step I need to disable all my plugins, but if I disable all-in-one then the site crashes.
    I need you to help me fixing this. I don’t know why you marked this issue as “resolved”…
    Thanks

    Plugin Author Yani Iliev

    (@yaniiliev)

    1. Enable WP_DEBUG in wp-config.php
    2. Refresh you website
    3. It will tell you what the issue is. At this point you need to figure out how to fix the issue. Googling the error might give you hints.

    This is what I get in debug.log:
    [23-Dec-2018 19:54:57 UTC] PHP Notice: Undefined index: insta_tag-userid in /home/peeklanc/public_html/florentin-magazine.com/wp-content/plugins/insta-gallery/app/wp-front.php on line 201

    Seems nothing is related to All-in-one.

    What should I do next?

    Plugin Author Yani Iliev

    (@yaniiliev)

    Try to disable this plugin. You can also reach over to the plugin author and ask them for assistance.

    Thats not what causing the problem.
    I removed this plugin and problem remains.

    Plugin Author Yani Iliev

    (@yaniiliev)

    What message do you see after removing the plugin?

    This page isn’t working
    florentin-magazine.com redirected you too many times.
    Try clearing your cookies.
    ERR_TOO_MANY_REDIRECTS

    Plugin Author Yani Iliev

    (@yaniiliev)

    Try adding the following code in your wp-config.php

    if ( isset( $_SERVER['HTTP_X_FORWARDED_PROTO'] ) && ( $_SERVER['HTTP_X_FORWARDED_PROTO'] === 'https' ) ) {
    	$_SERVER['HTTPS'] = 'on';
    }

    I am afraid this issue is not something that I can be of much help with. Better to work with your hosting provider support to try and figure it out.

    Ok, that worked.
    But I would like to know what does this line means?
    Why do I have to keep it forever?
    (if I remove it the site will crash, even after I removed all-in-one).
    Thanks

    I talked with my hosting provider, they said it’s not on their field, and it has something to do with WP/plugin itself.
    I have a good experience with them, and when they can help they do help.

    Plugin Author Yani Iliev

    (@yaniiliev)

    It is a server misconfiguration. Indeed, your hosting is the one that needs to fix it.

    The X-Forwarded-Proto (XFP) header is a de-facto standard header for identifying the protocol (HTTP or HTTPS) that a client used to connect to your proxy or load balancer. Your server access logs contain the protocol used between the server and the load balancer, but not the protocol used between the client and the load balancer. To determine the protocol used between the client and the load balancer, the X-Forwarded-Proto request header can be used.

    When someone accesses your website via HTTPS, PHP will set $_SERVER['HTTPS'] to on. On your server, it is not set and it causes the redirect loop https -> http -> https -> …

    emcphee

    (@emcphee)

    @shakarum
    Would you be so kind as to walk me through how to manually reactivate the All-In-One Migration plug in? I deactivated it and it crashed my site! I can get to wp-options but from there I can’t find where to “‘active plugins’ table.” I am not a coder and completely lost.
    Thank you!

    emcphee

    (@emcphee)

    I found the active plugins table! Now I just need to know how to add All-In-One Migration back to it…

Viewing 15 replies - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.