Support » Fixing WordPress » Deactivating plug-in wipes out blog (have searched forums)

  • As of today, when writing a post, I was unable to see the visual editor screen, only the code screen. I deactivated the TinyMCE plug-in, but when I tried to view my site, I got this:

    Fatal error: Cannot redeclare class addthis_social_widget_drop in /home/idothing/public_html/wp-content/plugins/addthis_social_widget_drop.php on line 13

    Note that this is the current error message. It may have been different immediately after I deactivated TinyMCE. I later tried deactivating some other plug-ins, tho I did not deactivate the “social add this” plug-in.

    I searched other similar problems on these forums and found references to replacing the functions.php or editing the wp-config.php file. I don’t have copies of these files anywhere but on my server, and when I try to open those files, nothing happens.

    I also found this: “Note that if it’s already deactivated, then deleting it won’t fix anything. Deactive and deleted are functionally equivalent. If you’re blog is still broken, then it’s because it’s trying to use a deactivated plugin.”

    Well, this is my situation. I deactivated the plug in, deleted it, and obviously this didn’t fix the problem.

    Can anyone help me, please?


Viewing 1 replies (of 1 total)
  • I think I accidentally fixed it. I deleted another plug-in (simple tags), and it’s working. I’ll have to do some more investigating, and would still appreciate anyone’s thoughts, but for now, I’m up and running.


Viewing 1 replies (of 1 total)
  • The topic ‘Deactivating plug-in wipes out blog (have searched forums)’ is closed to new replies.