Support » Plugin: iThemes Security (formerly Better WP Security) » Deactivated–now can't login in

Viewing 7 replies - 1 through 7 (of 7 total)
  • Handoko


    Please help. I just downloaded this app to my wordpress blog and now I can’t even sign in. It is giving me a 500 internal server error. I did do a backup, but I can’t get in to reinstall. Someone please help as I don’t know what to do and I don’t speak technical.

    Could someone please take pity on this dingbat and walk me through the process in English/non tech jargon of how I can fix this. I’m about to cry.




    First, you need to gain access to login to your backend. It’s easy, just follow this steps below:

    1. Login to your cPanel.
    2. Find an item called File Manager, click it.
    3. Browse to your plugin location. Normally it is in wp-content.
    4. Find a folder named …\plugin\better-wp-security.
    5. Rename the better-wp-security to better-wp-security-disabled.
    6. You should be able to login now.

    This not works for me. 🙁

    I rename better-wp-security to better-wp-security-disabled. And wp-admin again show blank page.

    How to delete this plugin. PLEASE HELP! :/



    Okay, if that first things don’t work for you, now you may try this second one.

    The most possible cause for your problem, I thinks is the configurations in your .htaccess file.

    1. Login to your cPanel.
    2. Find an item called File Manager, click it.
    3. Browse to your website location, usually is public_html (on left panel).
    4. Find a file named .htaccess.
    5. Save it on your local computer.
    6. Modify it on your local computer.
    7. Save (upload) it back to your website.

    Before you edit the .htaccess file, please make a backup of the .htaccess file. Improper editing of this file may cause your website totally fail to run.

    What things to modify in .htaccess file?
    You need to examine and edit the .htaccess file, pay attention of the texts between these lines:
    # BEGIN Better WP Security
    # END Better WP Security

    Delete any lines between the #BEGIN and #END WP Security.

    I change my .htaccess and now like this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    and wp-admin agan don’t work and show blank page.



    Strange. You website should working now. Did you also enable some other plugins? I mean basically this Better WP Security has removed from your website. Some data may still left in your website’s database, but it’s won’t do anything harmful.

    Previously, I told you to rename the folder to better-wp-security-disabled. Now, you may try delete the folder using your File Manager. And let’s see if it works.

    This plugin may cause 500 internal error, but only you enable certain features that consume much memory which is not allowed from your webhost.

    So, you may try:
    – Delete the better-wp-security-disabled folder.
    – Contact your webhost, they may able to fix it or at least tell you which plugin causing the error.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Deactivated–now can't login in’ is closed to new replies.