Support » Plugin: IP Geo Block » Deactivated after update – why?

  • Resolved hai3009

    (@hai3009)


    Hi,

    I use this phantastic plugin and it was realy a grest help for me!
    I have one question.

    Why is this plugin always deactivated after an update?

    This is bad, because i use an update program for my websites (InfiniteWP) and so I can’t see that it was deactivated for the last 3 weeks (after the last update).

    Is that an error or has this a special reason?

    Kind regards

    Horst

    https://wordpress.org/plugins/ip-geo-block/

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi Horst,

    Is that an error or has this a special reason?

    Well I do nothing special. I just prepare the activate and deactivate function as the normal way.

    I know nothing about InfinitWP. So I will check this plugin and try to find the cause of this issue.

    Please keep watching this issue.

    Thanks for your reporting.

    Hi,

    thank you for your answer. The deactivated It is not at all my WordPress blogs, but on the most. I dont think that this was an InfinyteWP issue because this Plugin I use at all my blogs.

    Maybe I gave you a wrong error message above, tah plugin is still activated under the plugins list, it is the orange hint on top of the WP backend that I must set the matching rule after the update.

    KInd regards

    Horst

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi Horst,

    Thank you for the information about your situation.

    1. At first, I’d like to understand exactly what your issue is. For the mutual understanding, please read this document: “Get Started“.

    2. You wrote:

    it is the orange hint on top of the WP backend that I must set the matching rule after the update.

    This means:

    • After updating plugins via InfinitWP,
    • you always find the orange hint i.e. “Welcome to IP Geo Block!! At first, please confirm “Matching rule” at Validation rule settings”.
    • And also you find the “Matching rule is Disable.
    • So you have to set it after every updating.

    Am I right?

    3. If the 2. is right, how about “Country code for matching rule“? Is it always empty? If so, your settings would be always initialized (3.1). On the other hand, if the country code remains there, only “Matching rule” would be initialized (3.2). Which is your situation 3.1 or 3.2?

    4. Please check your country code with “Scan your country code” especially the result of “Maxmind”. Does it tell your country code correctly?

    Please give me your suggestion about 2, 3 and 4.

    Thanks.

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Dear Horst,

    I installed InfiniteWP into my local PC and found your issue. To conclude, this issue is cause by the mechanism of InfiniteWP and their business model.

    InfiniteWP accesses to wp-admin of the target site directly and authenticate with their own authorization method (I don’t know exactly what it is). It means that this access has no admin authority for WordPress.

    On the other hand, most plugins have their own setting data which can be set only by whom has the admin authority. Of course, IP Geo Block has this type of setting data, and it should be set at least for the first installation by admin.

    For example, Wordfence is among the rest. I think we need some kind of special mediation software if we want to manage the WordPress admin via InfiniteWP. That’s why they sell addon for Wordfence.

    In case of IP Geo Block (like other plugins), once you set the “Matching rule” and other setting data, you can manage its updating via InfiniteWP.

    I expect you to understand this limitation.
    Thank you.

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Dear Horst and all,

    The previous my insight was totaly wrong. I’ll fix this issue in near future.

    Thank you very much, this is hitting me on several blogs as well! It seems to be happening every time the plugin updates itself. I get the “Welcome to IP Geo Block!! At first, please confirm “Matching rule” at Validation rule settings” prompt and the black/white/disabled is set to disabled.
    Cheers
    Nils

    Hi,

    thank you for your detailed answers!
    This is the result of my Country Code scan on 2 of my blogs with that error (deactivated whitelist):

    IP address : xxx.xxx.xx.xx
        Maxmind : n/a
        IP2Location : IP2Location.class.php: Unable to open file "/www/htdocs/xxx/cm/wp-content/plugins/ip-geo-block/ip-geo-api/ip2location/IP2LOCATION-LITE-DB1.BIN".
        freegeoip.net : DE
        ipinfo.io : DE
        IP-Json : DE
        Nekudo : DE
        Xhanch : DE
        geoPlugin : DE

    I try to deactivate and delete the plugin. After the re-install i receive an error (goggle translation):

    The plugin caused an error message 2201 characters unexpected output during activation. If you get error messages like "headers already sent", problems with syndication feeds or other of error, try the plugin to disable or delete them.

    Maybe it helps you.

    Kind regards

    Horst

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Dear Horst,

    Unfortunately, your activation fails for some reason because MaxMind answers “n/a” and IP2Location has an error. When the activation succeeds, the geo-location database are saved in /www/htdocs/xxx/cm/wp-content/ip-geo-api/ (not in the plugins directory) and you’ll find “DE” at both of them.

    I cannot identify the error because the message were supressed by means of “headers already sent“. So could you check if the /www/htdocs/xxx/cm/wp-content/ip-geo-api/ exists on your server?

    IGB will setup ip-geo-api directory into outside the plugins directory because it’s better to suppress the redundant downloading of databases at every upgrade. If you could not find it, please download it from https://github.com/tokkonopapa/WordPress-IP-Geo-API and put ip-geo-api under your /www/htdocs/xxx/cm/wp-content/ by using FTP or cPanel file manager.

    I already confirm this issue fixed with the following condition on my local environment:

    – IP Geo Block: 2.2.2.3 (the candidate for next release)
    – Infinite WP Admin Panel: v2.6.0
    – Infinite WP client: 1.5.0

    But the false of downloading database is another issue. Sorry for bothering you with this issue but I need your great help.

    Thank you!

    P.S. @nils, your issue might be fixed at next release. Please give me for some time. Thanks.

    Hi,

    hmm….
    I have now made the following on a new Blog.

    I have installed ip-geo-block

    Than I have downloaded the zip file from
    https://github.com/tokkonopapa/WordPress-IP-Geo-API

    Than I have copied the extracted folder “ip-geo-api” in the my folder /wp-content

    Than I want to set the white list by “Scanning Country Code” but I receive again theses error

    Maxmind : n/a
    IP2Location : IP2Location.class.php: Unable to open file "/www/htdocs/xxxx/cm/wp-content/ip-geo-api/ip2location/IP2LOCATION-LITE-DB1.BIN".

    But I was looking in the folder, and I must see that there is not such a file:
    IP2LOCATION-LITE-DB1.BIN

    Maybe this is the error?

    Kind regards

    Should I provide you with a login?

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi Horst,

    Thank you for setting up ip-geo-api. I should ask you to do one more thing.

    Please go to the setting page of IP Geo Block and execute “Download now” at “Local database settings“.

    If you succeed to download the DBs of MaxMind and IP2Location, you can “Scan your country code”. So please post the result here.

    Many thanks for your cooperation!!

    Nothing happens, always the same errors

    I set the arrow on delete all options on the bottom, than i delete the plugin
    than I upload the “ip-geo-api” folder in the /wp-content

    than I install again IP Geo Block

    than I receeiver the error “… Hedaer alredy sent…” and “…unexpected output during activation…”

    than i want to set the white list and hit on Scan for your country code
    same errors like above described

    than I want to download the Databse, nothing happend only the aninated Ajax pic appears.

    KInd regards

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi Horst,
    Thanks for reporting…

    Before further digging into this issue, I’d like to announce that I will release the versin 2.2.2.3 within a couple of hours (after sevral testing has finished) to fix 2 obvious bugs. I think this release cannot solve this issue, but I beg you to upgrade by your usual manner (via Ininite WP?) and please let me know something if your issue had changed.

    Then I will summarize the issues up to now.

    At first, I’d like to mention about the behavior of IP Geo Block especially at first installation and activation.

    1. Copy ip-geo-api to wp-content dirrectory.
    2. If it ends in success, (i.e. wp-content/ip-geo-api exists), then downloading geo-location DBs from MaxMind and IP2Location into wp-content/ip-geo-api will start at activation.
    3. If it ends in failure, (i.e. wp-content/ip-geo-api does not exists), then downloading DBs into wp-content/plugins/ip-geo-block/ip-geo-api will start at activation. This is the fallback process against No.2.
    4. In both cases, you can download manually at anytime from “Local database settings“.

    And your issues are:

    A. No.1 seems to fail.
    B. So you set up wp-content/ip-geo-api manually.
    C. When you try to download DBs manually, it seems to have started because the ajax spinner is running.
    D. But No.C seems to fail and the error message is always “Header already sent…”.

    So I think something prevents to download DBs and also prevents to output the error message. In order to identify the cause, I should know about the plugins and theme you are using, because something seems to conflict with IGB.

    To dig up the cause, I’d like to contact with you directly by email. Please send me an email to tokkonopapa at yahoo.com if you agree.

    Thanks so much for your kind cooperation!

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Dear all,

    Fixed this issue in 2.2.3.

    Thanks.

    GREAT!!!
    Now everything is working perfect!

    Thanks a lot !

    Hi,

    sorry but I receive again the same error on some blogs as before.

    IP2Location.class.php: Unable to open file "/www/htdocs/xxx/cm/wp-content/uploads/ip-geo-api/ip2location/IP2LOCATION-LITE-DB1.BIN"

    If I try to download manually I get the error “mkdir_failed_ziparchive” if I try to download the Files manually.
    Folder exists /wp-content/uploads/ip-geo-api/ip2location and has 777 permissions

    DOnt know why this is.

    Kind regards

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Deactivated after update – why?’ is closed to new replies.