WordPress.org

Support

Support » Multisite » DB tables for new subdomain site fail to get created

DB tables for new subdomain site fail to get created

  • I’ve got WP 3.0.5 running in a subdomain install, with the domain mapping plugin. It’s been working fine. I created up 5 blogs initially, and then installed the subdomain mapping plugin, and got it working fine. Several weeks passed, with writing and plugin isntallation/removal and all the other little changes that take place over time, and now I’m trying to create another new site, and it’s failing.

    When I look at the DB tables, the information for the new site is showing up in the Network wide tables (wp_blogs, etc) but it’s failing to create the new wp_N_posts, wp_N_comments, (etc) tables that would hold the content for that particular blog. The DB user has all privileges on the table of the blog DB, and I don’t see any explicit errors showing up in the debug.log pertaining to the table creation — though a huge number of them appear when it tries to actually *do* anything with those (non-existent) tables.

    Any ideas?

Viewing 15 replies - 1 through 15 (of 59 total)
  • though a huge number of [errors] appear when it tries to actually *do* anything with those (non-existent) tables.

    Well that one is obvious, right? 🙂 No tables = errors when you call them 😉

    Okay. So first step would be to see if YOU can make more tables manually. Go in via phpMyAdmin and just make a test table. Since you’ve been able to make tables before via WP, we know your ID has access, so it shouldn’t be THAT. But if WP’s getting a weird error, it may not kick out cleanly.

    (There’s an idea – After creating a subsite WP checks to make sure wp_#_options exists and, if not, says there’s an error and goes no further… or cleans up what it did.)

    Andrea Rennick

    @andrea_r

    Customer Care at Copyblogger Media and Studiopress

    Someone else ahs a thread complaining they can’t make new blogs after installing domain mapping. turn it off for 5 minutes, create a new blog. Does it work then?

    I did already try opening up mysql and creating a test table in the WP DB, and it worked fine. So I don’t think it’s a permissions thing.

    What’s the right way to turn off domain mapping? Can I just comment out the SUNRISE line in my wp-config file, or do I need to remove the mu-plugins directory, etc? I tried just commenting out SUNRISE and it didn’t fix the blog creation problem. Hmm.

    comment sunrise and remove the plugin from mu-plugins (or rename it .txt)

    Okay, I get the same behavior with domain mapping turned off: apparent success in creating the blog, existing tables (e.g. wp_blogs) are altered, but no new tables are actually created. Grr.

    Is your DB out of space?

    I doubt it, since I have my own VPS and I’m not having any trouble adding entries to other tables, and there’s no shortage of disk space. Is it possible that there could be a (very low) default quota set within mysql itself? I’ve never used quotas in mysql… not sure how to check that. Permissions on the directory that the DB files are stored in look okay too (all owned by mysql:mysql 660, directory is 700).

    Ugh. For no apparent reason, the problem has now gone away. All that happened in the meantime was that I re-activated domain mapping, and mapped a domain to one of the existing blogs. And now suddenly I can create a new blog, and all the DB tables get created just fine. So it seems that the problem is with the domain mapping plugin somewhere.

    Andrea Rennick

    @andrea_r

    Customer Care at Copyblogger Media and Studiopress

    Have you looked at any error logs? That’s not a lot for the devs to go on….

    I wasn’t able to find any useful error logs. Just a spew of errors when WP tried to do things with the tables that should have been created but weren’t. Where would you suggest looking?

    Andrea Rennick

    @andrea_r

    Customer Care at Copyblogger Media and Studiopress

    new updates to the plugin coming soon for 3.1 too.

    Just updated to 3.1, and so far I like it — the separation of network from individual site administration is much cleaner

    So, I’m now running 3.1.1 and trying to create another blog in my network install, and am having exactly the same problem. The new tables just don’t get created. The DB user that the site is running under has all privledges on the DB, and I still don’t know where to find any potential DB error logs. Tried disabling domain mapping (which in some mysterious way temporarily fixed this issue before) but it didn’t seem to work. AUGH!

    I’m fishing…

    What versions of PHP and MySQL are you using?

    Is your DB using MyISAM?

    mysql –version yields:

    mysql Ver 14.14 Distrib 5.1.41, for debian-linux-gnu (x86_64) using readline 6.1

    output from phpinfo() can be seen here:
    http://zaneselvans.org/php-version.php

    and indicates I’ve got PHP Version 5.3.2-1ubuntu4.7

    In my DB datastore, I see .MYD and .MYI files, so I assume I’m using MyISAM. It’s the default, right? I didn’t tell it to do anything special on install.

    insert_blog() appears to be succeeding, as the wp_blogs table is updated with the new blog_id, domain, etc. But then install_blog() is failing — none of the additional tables are actually created. I tried changing the call to wp_db_current_silent() to wp_db_current() in hopes of getting some kind of error/progress output within install_blog() inside ms-functions.php but got nothing.

Viewing 15 replies - 1 through 15 (of 59 total)
  • The topic ‘DB tables for new subdomain site fail to get created’ is closed to new replies.
Skip to toolbar