Support » Plugin: Simply Schedule Appointments » DB Query Errors

  • Hey there,

    When I have this plugin active I am seeing the following database errors:

    DESCRIBE jhdmmghb_ssa_async_actions;
    Table 'db_dom25128.jhdmmghb_ssa_async_actions' doesn't exist
    CREATE TABLE jhdmmghb_ssa_async_actions (
    id BIGINT(20) UNSIGNED NOT NULL AUTO_INCREMENT, 
    author_id BIGINT(11) UNSIGNED NOT NULL DEFAULT '0', 
    hook VARCHAR(255) NOT NULL DEFAULT '', 
    action VARCHAR(255) NOT NULL, 
    priority INT(5) NOT NULL DEFAULT '10', 
    payload TEXT NOT NULL, 
    object_type VARCHAR(255) NOT NULL, 
    object_id BIGINT(11) UNSIGNED NOT NULL DEFAULT '0', 
    action_group VARCHAR(255) NOT NULL, 
    response TEXT NOT NULL, 
    date_created DATETIME, 
    date_modified DATETIME, 
    date_queued DATETIME, 
    date_processed DATETIME, 
    process_batch_token VARCHAR(255) NOT NULL, 
    date_completed DATETIME, 
    PRIMARY KEY (<code>id</code>),
    KEY <code>author_id</code> (author_id),
    KEY <code>hook</code> (hook),
    KEY <code>action</code> (action),
    KEY <code>date_queued</code> (date_queued),
    KEY <code>date_processed</code> (date_processed),
    KEY <code>date_completed</code> (date_completed),
    KEY <code>process_batch_token</code> (process_batch_token) ) CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci COMMENT='Created with schema v1.8.2.021 (2019-02-08 23:12:03)'
    Index column size too large. The maximum column size is 767 bytes.
    DESCRIBE jhdmmghb_ssa_async_actions
    Table 'db_dom25128.jhdmmghb_ssa_async_actions' doesn't exist

    I checked the database and don’t see this table. I tried deactivating and reactivating to see if it would be created but no dice.

    Any advice? Has anyone else reported this? I’m going to take a look at the code to see where this table is supposed to be created.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author croixhaug

    (@croixhaug)

    Hey @dlocc! Thanks for reporting, we’ve not seen this issue reported yet – or in any of our test environments. Would love any extra debug info you can provide. If you install in a different environment do you get the same error? Also please try deleting the “ssa_async…” (not positive of the name) option from the options table

    Could you also send us a message through the SSA support tab so we can see your MySQL version?

    Thanks,
    Nathan

    Hey @croixhaug – I tried sending in app and got:

    Unable to send your message
    Something stopped us from being able to send your message, but never fear. You can simply email us at

    I’ll email you direct now.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.