Support » Plugin: DB Toolkit » DB Permissions

  • Hi,

    What other access rights do I need to give a user who needs to update some tables via the DB-Toolkit plugin? I created a new Role using the Members plugin with the rights “publish_posts” and “read” but when they try to update a record they get the error;

    You don’t have permission to access /wordpress/wp-admin/index.php on this server.
    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    Any ideas?


Viewing 2 replies - 1 through 2 (of 2 total)
  • UPDATE: I just tried this with Administrator rights and I get the same error.

    Also, the publish-posts is assigned to the Effective Capability Permission drop down on the Permissions section of the Interface.

    UPDATE2: OK, getting somewhere….it seems to be when BulletProof Security has been enabled and the BulletProof Modes for the Root Folder and wp-admin Folders are set to BulletProof Mode on the .htaccess files.

    What custom code needs to be added to that file to prevent the error from appearing?

    I’ve also seen that the record change does actually get written to the DB once the user re-logs in and views the record. So this looks like a .htaccess file problem rather than a DB-Toolkit problem….

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘DB Permissions’ is closed to new replies.