Support » Plugins » DB Backup folder visible to the public

  • Resolved paulacooney

    (@paulacooney)


    I just upgraded to 2.8. Before I did so I was prompted to do a backup and so installed the DB Backup plugin and backed up. Now there is a big bold messsage in wp-admin saying:

    Your backup folder MIGHT be visible to the public

    To correct this issue, move the .htaccess file from wp-content/plugins/wp-dbmanager to /home/websitename/public_html/wp-content/backup-db

    The problem is I’m not sure where to find the file or how to move it. Do I do this inside wp-admin somewhere or do I use my ftp program to view the files on the server and then somehow move it?

    As you can see I’m a raw newbie

    Thanks for the help

Viewing 15 replies - 16 through 30 (of 35 total)
  • It is NOT a folder. It is a file, the file name in the zip is called “htaccess.txt” You have to rename it to “.htaccess” and upload it to your backup folder directory. Defaults to “/wp-content/backup-db/”

    I had this same problem and the answer is here, although it took me a minute to put the pieces together. If your situation is like mine:

    the htaccess.txt file was in the /wp-content/plugins/wp-dbmanager folder

    i had no folder /backup-db in my /wp-content folder. i created one.

    i used my ftp client to move the htaccess.txt file to my desktop, then added it to the new /backup-db folder via ftp

    my mistake was this: i changed the file to .htaccess.txt — not realizing that the .txt should be removed. i sort of glossed over it. anyway, by removing .txt and adding a . (period) in front of .htaccess, the warning message disappeared.

    when you add the . in front of .htaccess the file will disappear from the folder, but that is expected. the . makes the file hidden, from what i understand.

    anyway, it worked. hope it helps.

    I still find it very unstable. It worked for me on one site, but doesn’t on another. Backup-db folder is there, .htaccess file is within it, the folder it CHMOD’d to 777, yet still the message. Definitely a buggy stuff. However it worked on another blog. All I can say is – unstable

    Hi

    I just thought I’d add that i had the same problem some mentioned here where the /backup-db folder was inaccessible to me with my ftp client.

    In order to get the htaccess.txt file (re named to .htaccess) in the /backup-db folder and in doing so to get rig of the annoying message in WP admin I simply created a new folder on my computer called backup-db and put the .htaccess file within it (since our pcs won’t show the .txt end of the file name you’ll need to change the name while it’s still in the /wp-content/plugins/wp-dbmanager folder with your FTP client before you download it to your pc), I then deleted the /backup-db folder with my FTP client (while the plugin was deactivated)and uploaded the pre prepared folder on my PC to the /wp-content folder.

    After doing this once i had the plugin re activated i no longer got the annoy message in my admin 🙂

    Hope this helps others

    Jayen

    mmm, I’m afraid this issue is not resolved after all 🙁

    Although moving the htaccess.txt file to the backup-db folder and re naming it to .htaccess worked fine on one of my sites, it is not working on another.

    The blog runs version 2.8 of WP and is installed in a sub directory of the site. And yes the file name is definitely correct, i copied it across from my PC using the very same file i had saved to my other sites backup-db folder which worked perfectly (as stated in my post above).

    Jayen

    I was having the same issues described above. What finally worked for me is adding the period in front of the name of the file. That’s what made the warning finally go away.

    The /wp-content/backup-db folder is not accessible by me.

    So, i can’t upload the .htaccess to that folder so that big bold messsage in wp-admin saying: “Your backup folder MIGHT be visible to the public” cannot be removed.

    Any solutions for this?

    The problem is you need to specify the full path, not just the sites root path

    /home/username/public_html/wp-content/backup-db

    To everyone else saying this is unstable or useless plugin shame on you… please uninstall it now and move along.

    Thanks GamerZ for a wonderful plugin.

    HI: Problem Solved I did not rename the file correctly.

    Just Follow the instructions to the tee and all is well.

    Thanks
    John

    it might be handy to put a guess to the root path to the wordpress dir on the specific webhost inside the box where it asks for the backup path, might help.

    Hanzo

    (@scorpionlgr)

    Thanks for the information, it helped me

    A fine lot of good this thread does me!

    I got the message when I signed up to use WordPress with a blogger’s site, because that was what they required. I do not have a WordPress site, I have not downloaded any WP software.
    I did download Google Gears, and my browser tells me that I have to activate it for the WP site I wish to participate in. With a funky message like:

    Your backup folder MIGHT be visible to the public

    To correct this issue, move the .htaccess file from wp-content/plugins/wp-dbmanager to /home/persist2/public_html/wp-content/backup-db

    I am reluctant to turn on the Google software. So, what to do?

    /s/ Former Big Iron Guy

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    I got the message when I signed up to use WordPress with a blogger’s site

    If it really concerns you, ask the folks who manage the WordPress site you signed up on. Although it sounds like you signed up to a service that installs WordPress for you.

    If you are going to blog that way and don’t know about the software, you really need to make sure that company keeps your installation current and secure.

    If you may also want to make sure in the DB Options of the plugin that the “Path To Backup:” correctly navigates to your backup-db folder.

    It navigates from your server root directory, so be sure to enter the right navigation otherwise you will get this error too.

    i.e. /var/www/domain.com/public_html/wp-content/backup-db

Viewing 15 replies - 16 through 30 (of 35 total)
  • The topic ‘DB Backup folder visible to the public’ is closed to new replies.