Support » Plugin: BackWPup - WordPress Backup Plugin » Db back up fails with Memory error

  • Resolved alan555

    (@alan555)


    I am running BAckWPUp on several sites with no problems but on a new site the backup fails on a Db back up. It works fine on the site files and completes without a problem.

    I have deleted the job and created a new Db back up job but still the same error. I also have the plugin running on a site on the same server and the Db backup works fine.

    Here is the error – it causes the server to go 100% CPU and limiting kicks in:

    [INFO] BackWPup 3.6.6; A project of Inpsyde GmbH
    [INFO] WordPress 4.9.8 on https://MYSITE.com/
    [INFO] Log Level: Normal
    [INFO] BackWPup job: DB
    [INFO] Logfile is: backwpup_log_01e59a_2018-12-04_11-29-21.html
    [INFO] Backup file is: Db_2018-12-04_11-29-21_OAA6LGQU03.tar.gz
    [04-Dec-2018 11:29:21] 1. Try to backup database …
    [04-Dec-2018 11:29:21] Connected to database MYSITE_XXXX on localhost
    [04-Dec-2018 11:29:21] ERROR: Allowed memory size of 385875968 bytes exhausted (tried to allocate 1701601920 bytes)
    [04-Dec-2018 11:29:22] 2. Try to backup database …
    [04-Dec-2018 11:29:22] Connected to database MYSITE_xxxx on localhost
    [04-Dec-2018 11:29:22] ERROR: Allowed memory size of 385875968 bytes exhausted (tried to allocate 1279410544 bytes)
    [04-Dec-2018 11:29:22] 3. Try to backup database …
    [04-Dec-2018 11:29:22] Connected to database MYSITE_XXXX on localhost
    [04-Dec-2018 11:30:25] ERROR: Maximum execution time of 60 seconds exceeded
    [04-Dec-2018 11:30:25] ERROR: Aborted by user!
    [04-Dec-2018 11:30:25] ERROR: Job has ended with errors in 64 seconds. You must resolve the errors for correct execution.

    Alan

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support duongcuong96

    (@duongcuong96)

    Hi @alan555,
    Please go to BackWPup > Settings > Jobs, try to set Maximum Script Execution Time setting to about 25 seconds and reduce server load to medium by going to BackWPUp -> Settings -> Job tab -> Reduce server load, select medium.
    After that, save the setting then try run the job again.
    Is that help?

    Unfortunately it did not fix it. The main site backs up just fine with default settings too so I feel it is just something odd on the database side of the site.

    I have added a different back up solution for the database in the meantime.

    Plugin Support duongcuong96

    (@duongcuong96)

    Hi @alan555,
    So I think this solution from stefanp44 may help you πŸ™‚
    https://wordpress.org/support/topic/allowed-memory-size-of-xxx-exhausted-tried-to-allocate/#post-10100334

    My host support came up with a solution this afternoon: if you can set up your server PHP version and activate some PHP extensions, instead of using pdo and mysql, they had me use nd_pdo and nd_mysql.

    I don’t know what it means (yet) but it works, the backup is effective again.

    Hope that useful πŸ™‚

    Yes works fine.
    Thank you.

    Plugin Support duongcuong96

    (@duongcuong96)

    @alan555
    Glad that it’s working for you :),
    If you have any question or issues about BackWPUp, feel free to let us know πŸ™‚
    Have a nice day :).

    Btw, If you find BackWPUp is useful for you, we would really appreciate if you leave a positive review and rating.
    This would encourage us to develop new free features and provide free support πŸ˜€
    https://wordpress.org/support/plugin/backwpup/reviews/

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Db back up fails with Memory error’ is closed to new replies.