Support » Plugin: Forminator - Contact Form, Payment Form & Custom Form Builder » Datepicker does not display icons correctly

  • Resolved lineadiconfine

    (@lineadiconfine)


    Greetings,
    I tested the free version of the “Forminator” plugin in a workspace and created a form to replace “Gravity Forms” on a client’s site and everything worked perfectly.
    Subsequently in a staging of the production site I installed “Forminator” and imported the setups. I realized that the “Datepicker” does not correctly display the icons for scrolling the months and not even the calendar icon.

    Datepicker does not display icons correctly: https://postimg.cc/GTymRQ68

    I have deleted the cache plugins, both Wp-Rocket, Autoptimize, and Siteground-Optimizer but I still haven’t solved.

    Also I noticed that when I “Preview” the form, the “DatepPicker” is correctly displayed.

    How can I try to fix this problem?
    Thanks, Alessandro.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Pawel – WPMU DEV Support

    (@wpmudev-support9)

    Hello Alessandro!

    Hope you’re having a good week!

    It looks like something form the theme or another plugin is overriding the CSS for the icons in the date picker. It changes the “content” property to something that’s not included in the Forminator font, so it’s not showing up.

    This should be easy to fix though – please add the following CSS in any one the usual places (Appearance >> Customise >> Additional CSS etc.) or you can add it on the form’s edit page in the Appearance tab by using the Custom CSS option:

    .ui-datepicker.forminator-calendar--default .ui-datepicker-header .ui-corner-all.ui-datepicker-prev:before {
    content: "❮" !important;
    }
    
    .ui-datepicker.forminator-calendar--default .ui-datepicker-header .ui-corner-all.ui-datepicker-next:before {
    content: "❯" !important;
    }

    Warm regards,
    Pawel

    Thread Starter lineadiconfine

    (@lineadiconfine)

    Hello,

    thank you very much, because the code you provided works well and the icons to scroll through the months work correctly.
    However I still can’t see the calendar icon.

    How can I solve this problem?

    Greetings!
    Alexander

    Plugin Support Nebu John – WPMU DEV Support

    (@wpmudevsupport14)

    Hi @lineadiconfine,

    Please try adding the following CSS along with the CSS provided in our previous response.

    span.forminator-icon-calendar {
        z-index: 9999;
    }

    I hope that helps. Please let us know the result.

    Best Regards,
    Nebu John

    Thread Starter lineadiconfine

    (@lineadiconfine)

    the code works perfectly. Thank you for the support!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.