Support » Plugin: Latest Tweets Widget » date_default_timezone_set() Timezone ID is invalid

  • Resolved jacob.dubail

    (@jacobdubail-1)


    Hi Tim,

    Great plugin. Thanks.

    I’m getting this error on my localhost as well as a MediaTemple DV:

    NOTICE: wp-content/plugins/latest-tweets-widget/latest-tweets.php:83 - date_default_timezone_set(): Timezone ID '' is invalid

    I can save the General Settings page to make it go away for a few hours, but then it comes right back. Any ideas?

    I’ve set my timezone to UTC-8. Do I need to set it to a specific city?

    Thanks,
    Jacob

    http://wordpress.org/plugins/latest-tweets-widget/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author timwhitlock

    (@timwhitlock)

    Your WordPress option timezone_string is empty in the example above. Saving your general settings will fix that (as you saw) but I don’t know why the option would empty itself out after a few hours.

    All I can tell you is that my plugin doesn’t overwrite timezone_string – it just uses it. It could however be another plugin overwriting it.

    I’ll patch my plugin to avoid using an empty timezone_string at line 83, but that won’t actually solve your problem if something is destroying your settings.

    Choosing an option with or without a city shouldn’t make any difference, but I’d recommend setting your actual location as otherwise your timezone’s daylight saving might won’t work. (guessing)

    I’d also recommend you ensure your PHP/server config has date.timezone set properly to the same region, e.g. “America/Los_Angeles”.

    Thanks. Makes perfect sense.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘date_default_timezone_set() Timezone ID is invalid’ is closed to new replies.