Support » Plugin: Custom Simple Rss » date_after filter apparently not working

  • Resolved bruce4bama

    (@bruce4bama)


    Hi. I’ve had pretty good luck with your plugin, but am having trouble with the “date_after” filter. I’ve double and triple-checked the syntax. I’m puzzled about what I’m doing wrong.

    Here’s the CSR feed URL I’m trying to use:

    When I go to this URL, I get an XML file that contains 10 posts, some of which are older than 1 week. When I change the parameter to “1 day ago”, I get the same 10 posts in the XML feed.

    I hope someone can tell me how to resolve this and get the correct feed results to match the parameters. Thanks.

    -Bruce Milligan

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author danikoo

    (@danikoo)

    Hi
    you did everything almost right 🙂
    just add &csrp_date=1
    to activate the date filter

    by the way i am working on a URL builder cause you are right ! over time many new features were introduced by users request – and it became to complicated to manage

    Hope that helped
    and don’t forget to leave a good review if you feel like it 🙂

    All the best
    Danikoo

    Thanks! That’s exactly what I needed. Worked perfectly.

    FYI: I am integrating this CSR URL into a dynamic weekly MailChimp newsletter, using their FEEDBLOCK construct. I had to troubleshoot why the URL wasn’t working in that context. A light bulb finally went on and I found out that feed functionality was impaired by the spaces in the “csrp_date_after” parameter value of “1 week ago”.

    When I replaced spaces with the ascii equivalent of %20, it worked just as expected. The working parameter looked like this:

    csrp_date_after=1%20week%20ago

    As you work on your URL builder, it might help your users if you included a toggle check box for “Convert Spaces to ASCII” or something like that.

    Best wishes! I’m very happy with the granular control of this plugin and grateful for the support response!

    -Bruce

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.