WordPress.org

Ready to get started?Download WordPress

Forums

Fast Secure Contact Form
[resolved] date picker broken (6 posts)

  1. jrwmacdonald2
    Member
    Posted 1 year ago #

    After upgrading to 4.0.18 and WordPress 3.8 the date picker no longer functions. I see that a bug fix for the date picker was added in 4.0.18 - could it be incompatible with WP 3.8?

    Thanks for the help

    http://wordpress.org/plugins/si-contact-form/

  2. superman1203
    Member
    Posted 1 year ago #

    You are right as I'm having the same problem. I noticed though that the update is causing the 'date' field type to be saved as "text" instead of 'date'. If you use inspect element browser tool you'll see what I mean - tweak 'text' for the field type to say "date" and your date picker will appear - until you refresh of course. I don't now how to fix this in the source, but hopefully that helps someone identify the issue. Again "date" field type is being saved as "text" instead of "date".

    Here's a link to a screenshot of what i'm talking about, if it'll work... https://dl.dropboxusercontent.com/u/8100179/Screen%20Shots%20about%20date%20picker%20issue.png

  3. superman1203
    Member
    Posted 1 year ago #

    Seems to be a conflict in my theme. There is a theme update that fixed it (but i have to redo all my customizations).

    jrwmacdonald2 - change your theme to the default and see if the date picker works - if so - something in your theme is conflicting - good luck.

  4. jrwmacdonald2
    Member
    Posted 1 year ago #

    Yep I changed the theme and sure enough the datepicker worked - some conflict with the theme then... unfortunately I don't have a theme update to fix this. Strange that this would happen - the HTML that is produced is the same regardless of the theme both have type set as text but one works and the other not.

    Thanks superman1203

    If I figure out what i need to change with my theme I'll post it here... perhaps the plugin developers have some clues?

  5. superman1203
    Member
    Posted 1 year ago #

    Actually my theme update didn't fix - turns out (if i understand correctly) The plugin update included grabbing some info from the footer - which I was purposefully not loading on my page - i activated the footer on my page and bam- there was my date picker. So i just had to change how i displayed my custom page.
    Sorry - I know nothing about how to track down conflicts :(

    What theme are you using and can you try changing that page to a different page template within your theme to narrow down (this helped me too)?

    i did donate to the developer to get some "premium support" input and he explained my previous assumption was incorrect (date was supposed to be text - and when i changed it to date - it was forcing the browser picker to appear not the plugin picker) - shows how little I know. He was the one who suggested switching themes to see.

  6. jrwmacdonald2
    Member
    Posted 1 year ago #

    Thats the info I needed! Thanks. The template on that page was not calling the footer - by design. Changing the page template does the trick. Thanks for the help superman1203.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.