WordPress.org

Support

Support » Plugins and Hacks » Events Manager » [Resolved] Date picker and autocomplete problem

[Resolved] Date picker and autocomplete problem

Viewing 15 replies - 1 through 15 (of 33 total)
  • unauthorized access at http://www.der-backnanger.de/veranstaltungen-melden/

    Have you tried to temporarily:

    – deactivating all other plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).
    – switching to the default theme to rule out any theme-specific problems

    Plugin Author Marcus

    @netweblogic

    your jquery looks ok, I’d try angelonwl’s suggestion

    Okay, thanks, I will try that.

    I have got a form plugin (FS Contact Form) running that uses date picker as well. What happens when I deactivate this plugin? Are all my forms gone?
    Do you know?

    I really appreciate your excellent support. Cheers every so much.

    if you deactivated that plugin chances are you will lose all the forms which you have created using FS Contact Form

    also, EM Pro has this feature http://wp-events-plugin.com/documentation/custom-booking-forms/

    Okay, I deactivated the form plugin, same problem, no date picker and autocomplete.

    Is there a way to find out – with firebug or similar – where the script problem lies?

    Cheers again

    hi,

    Did you try to temporarily disabling all plugins excerpt Events Manager and reverting to default theme?

    other useful links
    http://www.nsbasic.com/app/tutorials/TT10.htm
    https://getfirebug.com/wiki/index.php/Firebug_Links#Tutorials

    Hi again,

    I disabled all the plugins, but didn’t go back to default theme because this is a live theme with 18.000 PI per month. Don’t wanna loose any settings.

    Can I disable just date picker and autocomplete for event manager?

    I want to upgrade to EM Pro version but need to sort this out otherwise no use for me.

    Cheers

    Plugin Author Marcus

    @netweblogic

    I’m going to release an update later today which may help with the datepickers. Since I can’t see the submission form, I can’t tell for sure.

    For the auto-complete, you can disable that by choosing to show a dropdown list of locations in Events > Settings > General > General Options

    Hi Marcus,

    Thanks for your help.

    Sorry the form was not on public. Now you should be able to see: http://www.der-backnanger.de/veranstaltungen-melden/

    Cheers again for amazing support.

    Plugin Author Marcus

    @netweblogic

    Definitely is a jquery issue. I’d say you need to first try your theme before I look into debugging the JS, because normally, this works fine. Example – http://demo.wp-events-plugin.com/submit-your-event/

    Since you don’t want to change themes, you can use live preview to test this out. Go to appearance, click preview under twentyeleven, and then navigate to your event form.

    Hi Marcus,

    Thanks for you patience.

    I changed to Twentyeleven. It works well – no problem with date picker. It’s obviously a theme conflict. But I need this theme. What can I do? Is this maybe a z-index level problem? I can’t see any javascript error messages in Firebug. Can you?

    Cheers

    Clemens

    hi, you can try to temporarily disable other custom javascript or jquery function which your theme loads e.g. header.php

    Hi again,

    How would I do that temporarily? Just delete the file? I’m paranoid about loosing my theme, although I’m on a daily backup.

    Cheers

    Clemens

    better to ask your theme provider about it however you can just comment the javascript includes on the header and no files should be deleted;

    Plugin Author Marcus

    @netweblogic

    e.g. add

    <!-- your js stuff -->

    around your js stuff

    when done, uncomment those bits at the start/end

    I do see an error actually but using google chrome – Uncaught TypeError: Cannot call method ‘getTitleId’ of undefined

Viewing 15 replies - 1 through 15 (of 33 total)
  • The topic ‘[Resolved] Date picker and autocomplete problem’ is closed to new replies.
Skip to toolbar