Support » Plugin: LH Buddypress Export Xprofile Data » Date issue upon export

  • Resolved buci

    (@buci)


    Hi,

    I think this plugin has been overlooked. It’s great because it’s simple but I have an issue when I try to export a field with date.

    It will give me something like :
    MM/DD/YYYY

    However, the date that were saved on the profiles were something like this :
    DD/MM/YYYY

    As a result, upon export, every date that is not compatible (MM is above 12 for instance), will be changed to today’s date. This make it quite impractical.

    Is there a way to fix this?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author shawfactor

    (@shawfactor)

    this cannot be an issue with my plugin. I say this as my plugin just uses the standard xprofile_get_field function.

    Obviously I cannot write code to handle every possible way other plugins save and retrieve data in the database. However if you need to work around this and can code you could utilise the ‘export_humans_profile_field_value’ filter on line 185 to masage how the data is exported.

    Thread Starter buci

    (@buci)

    Hi shawfactor

    Thank you for your reactivity.
    So I played a bit with the xprofile field and found out a solution.

    I changed the date format to “y-m-d” and the plugin worked as intended.

    The date format “d/m/y” does not work though.

    • This reply was modified 7 months, 2 weeks ago by buci.
    Plugin Author shawfactor

    (@shawfactor)

    okay sounds good I´ll resolve this thread then, although I will till monitor it if you have any issues. If you like the plugin, please consider leaving a review.

    pete

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Date issue upon export’ is closed to new replies.