Support » Plugin: RSVPMaker » Date is displayed in English

  • Resolved Robert

    (@robertlindeboom)


    From a certain update, the date (day and month) of an event are displayed in English instead of Dutch words. Other dates on the site are displayed correctly and WP settings are set to the right format. How to change this for this plugin?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author davidfcarr

    (@davidfcarr)

    Are you saying the dates were displayed correctly in an earlier release? Can you tell me even approximately when you noticed a change?

    Plugin Author davidfcarr

    (@davidfcarr)

    I put out an update that uses the WordPress wp_date function, which should take advantage of all the localization/internationalization work the WordPress team has done in the context of date handling. So you should see RSVPMaker event dates translated the same as post time dates.

    Thread Starter Robert

    (@robertlindeboom)

    I can’t find from which release things changed, hard to say because I did several updates and wanted to check someday if I could fix it myself, so it took some time. If the date-time-settings weren’t changed in the code, maybe the translation (.po/.mo) files did the magic?

    I just did the update to the latest version and it fixed the words (so thanks for that, that’s already a lot better), but not yet the right order. It now says:

    zondag mei 30, 2021 9:30 AM aan 10:30 AM

    but according to my WordPress settings it should be:

    zondag 30 mei 2021 9:30 aan 10:30

    (the word ‘aan’ is not correct, but I think that is something for the translation files)

    Plugin Author davidfcarr

    (@davidfcarr)

    Look at the Settings -> RSVPMaker screen. You can change the order by changing the PHP date codes. RSVPMaker doesn’t use the exact same sequence as WordPress uses for post dates (not necessarily what you would want).

    Thread Starter Robert

    (@robertlindeboom)

    O that’s right, thanks!

    Thread Starter Robert

    (@robertlindeboom)

    I think it still doesn’t work correctly for time settings. In settings it is set to 24 hours. My event is set to start at 19:00. The page displays 07:00 (without AM/PM).

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.