The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

[resolved] Date fotmat in the archive widget is incorrect (10 posts)

  1. aguseo
    Posted 4 years ago #

    I discovered that the date formatting in the archive widget is incorrect in Hungarian and I cannot change is. This has appeared recently, I think around the time I upgraded from 3.2.1 to 3.3.1

    The normal format would be:
    2011. november

    But I get this:
    2011. / november

    The slash is absolutely not needed. My date settings under general settings are the default Hungarian (Y. F j. l) but it anyway doesn't seem to influence how the date looks in the archive widget.

    You can check it on the following sites:
    (I'm giving more b/c I might be changing some.)

    Note: if I set the site language to English then I get the proper English formatted dates.

    Any help would be appreciated!

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  3. aguseo
    Posted 4 years ago #

    Yes, I tried.
    Just tested 3.2.1 and 3.3.1 on my computer, and the initial installation of 3.3.1 gives the wrong date format already. Right after installation, no plugins, no nothing.
    So it's an out-of-the box issue.

  4. esmi
    Forum Moderator
    Posted 4 years ago #

    And what date format have you set up in Settings -> General?

  5. aguseo
    Posted 4 years ago #

    I have what the installation gave me. It is set to the first option by default, which is Y-m-d.

    Also note, I installed the Hungarian version not the English, but I guess the only differene is the language file.

  6. esmi
    Forum Moderator
    Posted 4 years ago #

    It could be an issue in the Hungarian translation file for WordPress or the translation file for your current theme.

  7. aguseo
    Posted 4 years ago #

    If I change the template to Twenty Ten I still get the same issue.
    However, if I copy the language files of wp-content\languages\ from the 3.2.1 installation to the 3.3.1 installation, then it shows the correct date. So there must be something in the language files of 3.3.1.

    I'll try to find it...

  8. aguseo
    Posted 4 years ago #

    Okay,I narrowed it down as far as hu_HU.po (and .mo) file.
    However there is no date formatting in it that corresponts to 2012. / november, so nothing like 'Y. / F' or anything similar.

    Also I put all date formattings to 'fuzzy' so they don't get used and still no effect.

    Any ideas?

  9. aguseo
    Posted 4 years ago #

    Okay, I found it.
    I started going through the language file basically line by line. This line caused the trouble:
    (English) %1$s %2$d - (Hungarian) %2$d. / %1$s

    Just needed to remove the slash.

    esmi, thanks for you guidance! :)

    Problem solved.

  10. esmi
    Forum Moderator
    Posted 4 years ago #

    Glad to hear that you managed to solve the problem. :-)

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.