WordPress.org

Support

Support » How-To and Troubleshooting » Date format not being heeded

Date format not being heeded

  • I changed the date format in Options to l, j F, Y and it’s still being read in American m/d/y format which is not what I’m after. Yes, I saved options, yes, I refreshed the page and cleared the cache.

    Anyone know why?
    http://www.ulujain.org/blog/

    BTW, the search on this forum doesn’t work. It doesn’t find anything and if you use the “kick ass” Yahoo link, it generates a malformed XML error. Kick ass all right, guys! 😉

Viewing 13 replies - 1 through 13 (of 13 total)
  • 1. It might be that the date format is hard coded in your theme’s template file(s). It’s a bad habit of the theme authors 🙂
    2. On the main page of the forum there is a “sticky” post – with read background on the top! It reads: How to search…
    Worth to take a look at it.

    LOL, OK, but why bother offering a search function here at all if you want people to use Google? Just proves that common sense isn’t.

    Thanks for the answer re: date formatting regardless.

    Re: search. It used to work, but after the last upgrade/move of the forum it just broke. We would like to be fixed but the mods cannot do anything about it 🙁

    Yeah, fair enough, but my advice is not to suggest people do things if those things don’t work 🙂 Sure way to frustrate people.

    ???

    moshu didn’t suggest using this site’s search. He pointed you to a sticky post at the top of forums which describes how one can search support without using the (broken) site search. I don’t see an attempt to frustrate people, but to suggest a way of finding the information you need.

    Moshu may not have suggested that and it’s not what I said, but the lovely little search input box at the top of nearly every page on this site probably does suggest it. Most people on the Internet are well-trained enough now to RTFM when confronted by an issue so their first impulse would be to search using – you guessed it – the search box. It doesn’t work, does it?

    So, in an ideal world, the search input box should be replaced by a message telling people to use Googles’s site: search function (which is probably 7-14 days adrift of currency) rather than getting people like me (and others) to post here and whine about it and to be redirected to a sticky that tells people to use Google.

    Ergonomic web design!

    Just sayin’

    “Most people on the Internet are well-trained enough now to RTFM…”

    I couldn’t disagree with you more. 🙂

    Regardless, you’re preaching to the choir my friend. I don’t think there’s anyone on this forum that wouldn’t LOVE to have the search feature work, but we aren’t the ones who can do anything about it.

    Anyway, did you get your date issue fixed?

    So, in an ideal world, the search input box should be replaced by a message telling people to use Google

    If the folks who moderate these forums could make such changes, do you believe they’d bother with a sticky post on the topic?

    Basic points are: Search on this site is broken; it’s a “to be fixed” issue we are all waiting on (along with several other bugs the forums have been buzzed by of late); all available methods to inform members how to work around it have been availed upon.

    Certainly a better way to let members know it doesn’t work is to pull it, or inform them at the time they search, but I think the best solution is to get it fixed–which we can all agree is the smartest way to handle things, ergonomically or not.

    Anyway, did you get your date issue fixed?

    LOL, no…I reverted back to the default theme from the Ocadia one I downloaded and it still displays m/d/y despite what I set it to in Options. Oh well, I guess someone out there wants us all to be Americans 😉

    The date format is hard coded into the default theme, that’s why. 🙂

    Take a look at the template tags for time and date, and in whatever theme you want to use, figure out which tag it’s using (usually will be in index.php), and take a look at the parameters. If the theme creator has hard coded the format in the tag parameters, it will override your options.

    Well, back to moshu’s #1 (screw that #2!)…

    Look in the default theme’s various templates look for this:

    <?php the_time('F jS, Y') ?>

    Change the date format string to one more pleasing, or call your set date format like so:

    <?php the_time(get_settings('date_format')) ?>

    And before the question comes up, the reason the_time() is used here instead of the_date() is because the_date() is meant more for use as a section header, and only displays once per day on a page (no matter how many posts are from that day).

    Aw heck, I’m feeling generous tonight.

    In Ocadia, it’s hard coded.

    <?php the_date('m.d.y', '<h1 class="storydate">', '</h1>'); ?>

    Change that bit of code in index.php to the format you want it to be, and you’re set. 🙂

    Thanks guys, I changed the relevant part in index.php and all is peachy.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Date format not being heeded’ is closed to new replies.
Skip to toolbar