Support » Plugin: Legull » Date doesn't conform with WordPress format

  • Resolved eggplant_casserole

    (@eggplant_casserole)


    In the Terms, the date is displayed with [legull display=”last_updated”]. What is displayed is formatted as such:

    These terms were last updated on February 6th, 2015

    However, my site is set (in settings>general) to the first option, 6th February 2015.

    It is quite annoying when plugins choose to ignore the default date format set by WordPress. I am in the UK, we don’t say February 6th – that’s an Americanism. Could this be altered, so the plugin conforms to whatever date format is set in WordPress?

    I’m not an expert, but I think you need to use:

    get_option('date_format')

    Other than this, I’m enjoying the plugin – it’s very simple to use!

    Thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Timothy Wood

    (@codearachnid)

    I agree with the annoyance. I had anticipated enabling a way to filter the date; however, I have found from experience most general users don’t pay attention to the date format or format it in such a way that would be detrimental to the display of the date on the legal terms. I do think for a future release I will enable a filterable override – but as you suggest revert to using the format defined by WordPress.

    Plugin Author Timothy Wood

    (@codearachnid)

    This is scheduled for version 1.2.0 fix – https://github.com/codearachnid/legull/issues/13

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Date doesn't conform with WordPress format’ is closed to new replies.