Support » Fixing WordPress » Date based archive broken

  • Resolved distobj


    Hi. We recently moved a site to a new server and at the same time, changed the permalink structure. Now we’re noticing that date based archives – i.e. visiting “” and seeing August’s posts – aren’t showing up. Instead we just get redirected to the main blog page.

    .htaccess was successfully updated and now includes the boilerplate that performs the redirect to /index.php, but I guess this is interfering with something at the site. We’re using K2 as a theme, but I don’t know anything about it; could it be part of the problem?

Viewing 7 replies - 1 through 7 (of 7 total)
  • To exclude (or not) the possibility of being theme related – switch to another theme, like default or classic.

    Did the blog work on the new location before you started messing with the permalinks?

    Good thinking. I changed the theme back to WordPress default, but the problem still exists.

    We moved the server & switched permalinks at the same time, so never checked.

    Never make more than one major changes on a blog at one time…

    Was the earlier version also on a subdomain?
    What happens if you switch to the dfeault permalink settings? Does it work? Did you try other permalinks strcutures – just for testing?

    However, if certain permalinks work (e.g. single post view, category archives, index) and others don’t (e.g. monthly archives) – then it needs a closer look, which is always impossible at “”.

    Sorry, there was no subdomain. The site is and we have a staging site at where the problem can also be demonstrated.

    I tried changing the permalinks structure on “staging” to default, but even then, date archive links (using “?m=200808”) still redirect to the home page.

    Yes, individual post permalinks work fine.

    Thanks for your help.

    OK, the monthly archives don’t work on the main site either:

    I am afraid, without looking at the code and/or the files on the server it will be difficult to figure it out. There must be something that interferes with the virtual directories in the URLs for the monthly archives, as if something is redirecting it…

    Ok, thanks again for your help.

    I solved the problem, so I thought I’d let others now.

    At the same time as the move, we upgraded our plugins which included the Meta Robots plugin. Unfortunately, in my haste to upgrade, I didn’t notice that upgrading Meta Robots sets a bunch of options to “on” that were previously off. One of those options was “disable date archives”. Oops.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Date based archive broken’ is closed to new replies.