Support » Plugin: Contact Form 7 » dateフォームタグでautocomplete:bdayが無視されます。

  • php version: 7.3.17
    WP Core version: 5.5.3
    Contact Form 7 version: 5.3.1
    一応受託案件のため、参考URLを提示できません。ご了承ください。

    <label>生年月日 (必須)
        [date* birthday autocomplete:bday]</label>

    上記のようにフォームタグを打ちましたが、下記の通り変換され、autocompleteオプションが無視されます。

    <p><label>生年月日 (必須)<br />
        <span class="wpcf7-form-control-wrap birthday"><input type="date" name="birthday" value="" class="wpcf7-form-control wpcf7-date wpcf7-validates-as-required wpcf7-validates-as-date" aria-required="true" aria-invalid="false" /></span></label></p>

    現在、autocompleteオプションの存在を知るにはソースコードまたは変更履歴を見るしかない状況です。
    よって、これが仕様なのかバグなのかが判断できない状況です。
    以下に受託元などの情報を非公開としたサイトヘルスを張り付けておきます。

    
    ### wp-core ###
    
    version: 5.5.3
    site_language: ja
    user_language: ja
    timezone: Asia/Tokyo
    permalink: /%year%/%monthnum%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 0
    default_comment_status: undefined
    environment_type: production
    user_count: 16
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: (非公開)
    wordpress_size: 3.27 GB (3515379539 bytes)
    uploads_path: (非公開)
    uploads_size: 1.67 GB (1795279038 bytes)
    themes_path: (非公開)
    themes_size: 14.37 MB (15073045 bytes)
    plugins_path: (非公開)
    plugins_size: 21.35 MB (22387979 bytes)
    database_size: 15.77 MB (16531456 bytes)
    total_size: 5.00 GB (5364651057 bytes)
    
    ### wp-active-theme ###
    
    name: (非公開 自作テーマ),
    version: 0.5
    author: smc-power
    author_website: https://smc-power.jp/
    parent_theme: none
    theme_features: core-block-patterns, editor-style, editor-styles, title-tag, automatic-feed-links, align-wide, custom-line-height, html5, editor-color-palette, menus, widgets
    theme_path: (非公開)
    auto_update: 無効
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty: version: 1.5, author: WordPress チーム,自動更新無効
    
    ### wp-plugins-active (12) ###
    
    (非公開 自作プラグイン 用途:パーマリンク変更),
    Add From Server: version: 3.4.4, author: Dion Hulse, 自動更新無効
    All-in-One WP Migration: version: 7.31, author: ServMask, 自動更新無効
    Breadcrumb NavXT: version: 6.6.0, author: John Havlik, 自動更新無効
    Category Order and Taxonomy Terms Order: version: 1.5.7.3, author: Nsp-Code, 自動更新無効
    Contact Form 7: version: 5.3.1, author: Takayuki Miyoshi, 自動更新無効
    Plugin Notes Plus: version: 1.2.2, author: Jamie Bergen, 自動更新無効
    Regenerate Thumbnails: version: 3.1.4, author: Alex Mills (Viper007Bond), 自動更新無効
    Search Regex: version: 2.4.1, author: John Godley, 自動更新無効
    Ultimate Blocks: version: 2.4.2, author: Ultimate Blocks, 自動更新無効
    VK All in One Expansion Unit: version: 9.48.3.0, author: Vektor,Inc., 自動更新無効
    Widget Shortcode: version: 0.3.5, author: Hassan Derakhshandeh, 自動更新無効
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1650
    imagemagick_version: ImageMagick 6.7.2-7 2016-06-09 Q16 http://www.imagemagick.org
    file_uploads: File uploads is turned off
    post_max_size: 50M
    upload_max_filesize: 50M
    max_effective_size: 50 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 512 MB
    	imagick::RESOURCETYPE_DISK: 1.844674407371E+19
    	imagick::RESOURCETYPE_FILE: 49152
    	imagick::RESOURCETYPE_MAP: 4 GB
    	imagick::RESOURCETYPE_MEMORY: 2 GB
    	imagick::RESOURCETYPE_THREAD: not available
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 8.70
    
    ### wp-server ###
    
    server_architecture: Linux 4.19.56-300.131.1.hl6.x86_64 x86_64
    httpd_software: Apache
    php_version: 7.3.17 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 128M
    admin_memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 50M
    php_post_max_size: 50M
    curl_version: 7.48.0 OpenSSL/1.0.1e
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.23-log
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: (非公開)
    WP_PLUGIN_DIR: (非公開)
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: true
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    
Viewing 2 replies - 1 through 2 (of 2 total)
  • とりあえず WordPressデフォルトテーマ + Contact Form 7 でどうなのか?
    Contact Form 7以外のプラグインを停止してみて改善するかどうか確認してみてはどうでしょう?

    Thread Starter omaeyusuke

    (@omaeyusuke)

    @kurudrive そうですね、仮想の新環境で改めて行いました。

    <label>生年月日 (必須)
        [date* birthday autocomplete:bday]</label>

    としましたが

    <label>生年月日 (必須)<br>
        <span class="wpcf7-form-control-wrap birthday"><input type="date" name="birthday" value="" class="wpcf7-form-control wpcf7-date wpcf7-validates-as-required wpcf7-validates-as-date" aria-required="true" aria-invalid="false"></span></label>

    やはり変わらなかったです。

    ### wp-core ###
    
    version: 5.6
    site_language: ja
    user_language: ja
    timezone: +00:00
    permalink: /%postname%/
    https_status: false
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: local
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: C:\Users\cpgd0\Local Sites\test\app\public
    wordpress_size: loading...
    uploads_path: C:\Users\cpgd0\Local Sites\test\app\public/wp-content/uploads
    uploads_size: loading...
    themes_path: C:\Users\cpgd0\Local Sites\test\app\public/wp-content/themes
    themes_size: loading...
    plugins_path: C:\Users\cpgd0\Local Sites\test\app\public/wp-content/plugins
    plugins_size: loading...
    database_size: loading...
    total_size: loading...
    
    ### wp-active-theme ###
    
    name: Twenty Twenty-One (twentytwentyone)
    version: 1.0
    author: WordPress チーム
    author_website: https://ja.wordpress.org/
    parent_theme: none
    theme_features: core-block-patterns, automatic-feed-links, title-tag, post-formats, post-thumbnails, menus, html5, custom-logo, customize-selective-refresh-widgets, wp-block-styles, align-wide, editor-styles, editor-style, editor-font-sizes, custom-background, editor-color-palette, editor-gradient-presets, responsive-embeds, custom-line-height, experimental-link-color, custom-spacing, custom-units, widgets
    theme_path: C:\Users\cpgd0\Local Sites\test\app\public/wp-content/themes/twentytwentyone
    auto_update: 無効
    
    ### wp-themes-inactive (2) ###
    
    Twenty Nineteen: version: 1.8, author: WordPress チーム, 自動更新無効
    Twenty Twenty: version: 1.6, author: WordPress チーム, 自動更新無効
    
    ### wp-plugins-active (1) ###
    
    Contact Form 7: version: 5.3.1, author: Takayuki Miyoshi, 自動更新無効
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: 利用できません
    imagemagick_version: 利用できません
    file_uploads: File uploads is turned off
    post_max_size: 1000M
    upload_max_filesize: 300M
    max_effective_size: 300 MB
    max_file_uploads: 20
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: Windows NT 10.0 AMD64
    httpd_software: nginx/1.16.0
    php_version: 7.3.5 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 4000
    time_limit: 1200
    memory_limit: 256M
    max_input_time: 600
    upload_max_filesize: 300M
    php_post_max_size: 1000M
    curl_version: 7.64.0 OpenSSL/1.1.1b
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 8.0.16
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: C:\Users\cpgd0\Local Sites\test\app\public/wp-content
    WP_PLUGIN_DIR: C:\Users\cpgd0\Local Sites\test\app\public/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.