Support » Plugin: Yoast SEO » Database writing error

  • Resolved xchristox

    (@xchristox)


    I woke up this morning and none of my post are loading.

    YOAST is giving an error message in the WP dashboard saying my host is not allowing database writing and that THEY should fix it.

    However when checking the YOAST dashboard, it says 0 problems.

    SO i went on disabling each plugin one by one, and the last one of 20 seemed to do the trick: YOAST.

    I think it has something to do with the latest update. YOAST is disabled for now but please double check with latest version.

    Kind regards,

    Chris

    • This topic was modified 11 months, 4 weeks ago by xchristox.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support djennez

    (@djennez)

    @xchristox the warning about Yoast not being able to create tables should contain a link to this article: https://yoast.com/help/cannot-create-database-tables/ . Have you checked this article and contacted your host?

    Thread Starter xchristox

    (@xchristox)

    No because I run two similar websites on that same host and the other two websites with older versions of the plugin do not have the issue.

    Plugin Support djennez

    (@djennez)

    The update needs to create extra tables, so yes, older versions don’t have this issue because they are not updated…

    Please check if your database user has table creation and index rights on your database. If it does not, you can grant these permissions temporarily during the update and remove them after.

    14.0.2 should fix some additional database issues, but these tables still need to be created. So I don’t think waiting for 14.0.2 will solve the issue.

    Thread Starter xchristox

    (@xchristox)

    I will check with my host then. But still… it has been working for years. Now the error nearly kills the whole website. Host issue or not, it is still related to yoast and it could or should be an additional option to turn on or off. Now the whole plugin is useless until my host fixes something that has been working for years.

    I hope you get what I mean.

    Thread Starter xchristox

    (@xchristox)

    Well…. Yoast plugin updates once again. New release in the last 60 minutes. Version 14.0.1 and yes, it solved the issue!

    Is there something you are not telling me? I also do not see a changelog.

    Whatever it may have been, all of a sudden ot seems that 14.0.1 has fixed it for now.

    Thanks anyway.

    Plugin Support devnihil

    (@devnihil)

    @xchristox Thanks for confirming that the most recent update of Yoast SEO resolved the issue. We are going ahead and marking this issue as resolved. If you require any further assistance please create a new issue.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Database writing error’ is closed to new replies.