WordPress.org

Support

Support » Installation » Database will not let WP install, help?

Database will not let WP install, help?

  • I am trying to install wordpress for someone. His MYSQL is 4.0.20 and yet I am getting massive database errors.
    Database error: [You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ‘( ID int(10) unsigned NOT NULL auto_increment, post_author ]
    CREATE TABLE ( ID int(10) unsigned NOT NULL auto_increment, post_author int(4) NOT NULL default ‘0’, post_date datetime NOT NULL default ‘0000-00-00 00:00:00’, post_date_gmt datetime NOT NULL default ‘0000-00-00 00:00:00’, post_content text NOT NULL, post_title text NOT NULL, post_category int(4) NOT NULL default ‘0’, post_excerpt text NOT NULL, post_lat float, post_lon float, post_status enum(‘publish’,’draft’,’private’) NOT NULL default ‘publish’, comment_status enum(‘open’,’closed’) NOT NULL default ‘open’, ping_status enum(‘open’,’closed’) NOT NULL default ‘open’, post_password varchar(20) NOT NULL default ”, post_name varchar(200) NOT NULL default ”, to_ping text NOT NULL, pinged text NOT NULL, post_modified datetime NOT NULL default ‘0000-00-00 00:00:00’, post_modified_gmt datetime NOT NULL default ‘0000-00-00 00:00:00’, post_content_filtered text NOT NULL, PRIMARY KEY (ID), KEY post_date (post_date), KEY post_date_gmt (post_date_gmt), KEY post_name (post_name), KEY post_status (post_status) )
    Database error: [You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ‘(post_author, post_date, post_date_gmt, post_content, post_titl]
    INSERT INTO (post_author, post_date, post_date_gmt, post_content, post_title, post_modified, post_modified_gmt) VALUES (‘1’, ‘2004-08-17 19:31:45’, ‘2004-08-18 00:31:45’, ‘Welcome to WordPress. This is the first post. Edit or delete it, then start blogging!’, ‘Hello world!’, ‘2004-08-17 19:31:45’, ‘2004-08-18 00:31:45’)
    Database error: [You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ‘( cat_ID int(4) NOT NULL auto_increment, cat_name varchar(5]
    CREATE TABLE ( cat_ID int(4) NOT NULL auto_increment, cat_name varchar(55) NOT NULL default ”, PRIMARY KEY (cat_ID), UNIQUE (cat_name) )
    Database error: [You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ‘(cat_ID, cat_name) VALUES (‘0’, ‘General’)’ at line 1]
    INSERT INTO (cat_ID, cat_name) VALUES (‘0’, ‘General’)
    Can someone, anyone give me some insight into this?

Viewing 3 replies - 1 through 3 (of 3 total)
  • I would be checking directly with your host on this. Ensure that you have the minumum required MySQL available. It almost sounds to me like you don’t have a supported version.
    Then again I could be wrong, in which case I will just deny answering the question! 🙂

    The version of MYSQL is 4.0.20 and I am trying to help out another user. He is giving up on WP because no one knows how to get it installed. I think it is sad that this is the case.

    All of the SQL statements you posted have one thing in common: they’re missing a table name. So they’re not valid SQL no matter what the version.
    Do you perhaps have $table_prefix missing from your wp-config.php file? Or did you change it to something unusual? It should look like:
    $table_prefix = ‘wp_’;
    Otherwise, I don’t know why that would happen…

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Database will not let WP install, help?’ is closed to new replies.