WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Database Weirdnesses: Site Works, DB Backup Empty, Can't Upgrade

[Resolved] Database Weirdnesses: Site Works, DB Backup Empty, Can't Upgrade

  • The site is displaying perfectly. Please look at all the observations below before suggesting; it may rule out some possibilities.

    The WordPress Database Backup plugin produces ZERO-BYTE files.

    The automatic upgrade to WP 3.1.1 gives this error:

    Could not create directory.: /home/motorbik/public_html/wp-content/upgrade/wordpress-3.tmp

    Trying to upgrade any plugin gives this kind of error:

    An error occurred while updating Ozh’ Admin Drop Down Menu: Could not create directory. /home/motorbik/public_html/wp-content/upgrade/ozh-admin-drop-down-menu.tmp.

    I looked at the upgrade folder, and it has the same 755 permissions as other folders, and is the same on a site where this problem does not exist.

    Ideas?

    Lane

Viewing 4 replies - 1 through 4 (of 4 total)
  • esmi

    @esmi

    Forum Moderator

    Try changing the permissions on the wp-content directory to 766. If you still have problems, try 767, 775 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.
    http://codex.wordpress.org/Changing_File_Permissions

    Thanks, esmi! I tried all those values, but no luck.

    Lane

    esmi

    @esmi

    Forum Moderator

    It could be a folder ownership issue, I suppose. Have you asked your hosts about this? Do media files upload OK?

    I was going to file a ticket with my hosting company, but I decided to try something first to give me more to report.

    I tried to create a new folder myself with FTP, and I got this error:
    550 Can’t create directory: Disk quota exceeded
    : /public_html/wp-content/upgrade/dummy

    I just had too much stuff in that account! After I upgraded its quota, the WP and plugin updates went smoothly.

    Live and learn!

    Lane

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Database Weirdnesses: Site Works, DB Backup Empty, Can't Upgrade’ is closed to new replies.