WordPress.org

Support

Support » Installation » Database Upgrade Required: Not Working (WP 2.9)

Database Upgrade Required: Not Working (WP 2.9)

  • Hello. Longtime (5 years) user of WordPress on all of my domains. I went to upgrade to the new 2.9 version this evening and it worked fine, as always. When complete, a screen told me:

    Database Upgrade Required

    WordPress has been updated! Before we send you on your way, we have to upgrade your database to the newest version.

    The upgrade process may take a little while, so please be patient.

    Upgrade WordPress Database

    When I click on the button, it works for a moment and then sits on a WordPress logo with nothing else. I can now not log into my domain b/c it brings me back to this page!

    How can I rectify this situation?

Viewing 15 replies - 16 through 30 (of 40 total)
  • jamlz solution at http://www.clickonf5.org/wordpress/solution-database-upgrade-required/2247 fixed this for me. The new db_version is 12329 for WP 2.9. Thanks!

    Thanks–I was panicking and it’s now fixed with the change to 12329.

    that does not create the new wp_commentsmeta table in the db though. so you might be looking for trouble in the future!

    I’m wondering if there are any other database changes we can apply manually other than this? My database is around 300MB and no matter what changes I do to the php.ini file, the upgrade process simply times out.

    for those interested, the SQL code you need to run to create the new wp_commentmeta table is:


    CREATE TABLE IF NOT EXISTS
    wp_commentmeta (
    meta_id bigint(20) unsigned NOT NULL auto_increment,
    comment_id bigint(20) unsigned NOT NULL default ‘0’,
    meta_key varchar(255) collate utf8_unicode_ci default NULL,
    meta_value longtext collate utf8_unicode_ci,
    PRIMARY KEY (meta_id),
    KEY comment_id (comment_id),
    KEY meta_key (meta_key)
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci AUTO_INCREMENT=1 ;

    Any others changes to the db please?

    HELP, please!

    I have the same issue…
    When trying to access the wp-admin i get redirected to the ‘Database Upgrade Required’ page. After clicking the button i get ‘Upgrade Complete’ and then it just loops back to the ‘Database Upgrade Required’ page. I.E. I cant access admin.

    I’ve tried this solution:
    http://www.clickonf5.org/wordpress/solution-database-upgrade-required/2247
    -It did not work, versions checks out in db & version.php

    System Requirements are ok, phpinfo says:
    memory_limit = 512M
    Client API version = 5.1.41

    Any help suggestions?
    Sadly and VERY anoying is that I dont have a backup since before the upgrade…

    To the WordPress developers:

    Please stop releasing new versions without thorough testing…this is what happens when you keep releasing new versions every couple of months….Geez.

    I am also having a problem auto upgrading…I get the fatal error message and not having enough memory.

    I am holding back on this upgrade until Automatic comes up with a more trouble free version.

    It seems a lot of people are having problems and more will come here reporting problems….in the coming days…the availability of auto upgrade means a lot of people wont backup their database and when they run into problems, it will be HEADACHE.

    @bliss7:

    If you’re not configured for enough memory, then your server needs to be adjusted to allow you to use more memory.

    Upgrades are memory intensive. This cannot be changed. No amount of “testing” would have helped you, because the problem isn’t in WordPress, it’s in your server configuration.

    There will be no “fix” for lack of memory. Fix your server configuration.

    More info: http://www.google.com/search?q=php+memory+limit

    @ Otto,

    Sorry if I sounded annoyed, but:

    1) I never had memory problems for a long time. Is WordPress getting more resource intensive?

    2) It seems memory is not the only problem happening, but database problems as well…I don’t fancy rolling back

    3) This problem is being reported in various shapes and forms across the forum now, so I’m not barking in the wind.

    Rgds

    There will be no “fix” for lack of memory. Fix your server configuration.

    @otto42 – Your response fails to take into account how people are actually using WordPress. What percentage of folks using WP are doing so on their own server vs some sort of hosted environment? I don’t have that kind of control over “my” server; most people don’t.

    Moderator Mark Ratledge

    @songdogtech

    Forum Moderator

    john: usually you have some control even if you don’t run your own server; you can try increasing the memory for PHP and WordPress by putting this line in your .htaccess file:

    php_value memory_limit 64M

    or this line near the top of your wp-config.php file:

    define('WP_MEMORY_LIMIT', '64M');

    or in your php.ini:

    memory_limit = 64M;

    @otto42 – Your response fails to take into account how people are actually using WordPress. What percentage of folks using WP are doing so on their own server vs some sort of hosted environment? I don’t have that kind of control over “my” server; most people don’t.

    Then you need to talk to the people who do control your server and ask them how to do it, or if they can do it for you.

    @otto42,

    Respectfully, it’s one thing if the WordPress development team doesn’t have enough resources to test all possible upgrade scenarios (for example, low memory limit hosted environments), but to say no amount of testing would have uncovered this is simply false.

    @jalmz than you for the link, this fixed my issue with he db versions not matching up! 🙂

    @matoo

    thank youuuuu

    i read this topic and Matoo’s technic work.

    My site come back
    🙂

    when i was activate plugins
    i get this error:
    ***
    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 311296 bytes) /wp-includes/canonical.php on line 277
    ***

    and reurn to change my plugin setting

    http://www.sitename/wp-admin/

    i get same error

    :)))

    i can’t access wp-admin
    🙂

    Thank you everyone for the great details here. There is enough information to identify an obvious flaw in the new version of WordPress. I will make sure it is reported correctly in Trac.

Viewing 15 replies - 16 through 30 (of 40 total)
  • The topic ‘Database Upgrade Required: Not Working (WP 2.9)’ is closed to new replies.
Skip to toolbar